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Introduction 
 
About CommView for WiFi 
 
CommView for WiFi is a special edition of CommView designed for capturing and analyzing network packets on wireless 802.11b 
networks. It gathers information from the wireless adapter and decodes the analyzed data. 
 
With CommView for WiFi you can see the list of network connections and vital IP statistics and examine individual packets. Packets 
can be decrypted utilizing user-defined WEP keys and are decoded down to the lowest layer, with full analysis of the most 
widespread protocols. Full access to raw data is also provided. Captured packets can be saved to log files for future analysis. A 
flexible system of filters makes it possible to drop unnecessary packets or capture the essential packets. Configurable alarms can 
notify the user about important events, such as suspicious packets, high bandwidth utilization, or unknown addresses. 
 
CommView for WiFi features full decoding of the following protocols: ARP, BCAST, BGP, BMP, CDP, DAYTIME, DDNS, DHCP, DIAG, 
DNS, EIGRP, FTP, G.723, GRE, H.225, H.261, H.263, H.323, HTTP, HTTPS, ICMP, ICQ, IGMP, IGRP, IPsec, IPv4, IPv6, IPX, HSRP, 
NCP, NDS, NetBIOS, NFS, NLSP, NTP, OSPF, POP3, PPP, PPPoE, RARP, RADIUS, RDP, RIP, RIPX, RMCP, RPC, RSVP, RTP, RTCP, 
RTSP, SAP, SER, SMB, SMTP, SNA, SNMP, SNTP, SOCKS, SPX, TCP, TELNET, TFTP, TIME, UDP, VTP, WAP, WDOG, 802.1Q, 802.1X. 
 
CommView for WiFi is a helpful tool for WLAN administrators, security professionals, network programmers, or anyone who wants 
to have a full picture of the WLAN traffic. This application runs under Windows 2000/XP and requires a compatible wireless network 
adapter. For the list of supported adapters, please see the Driver Installation chapter.  
 



 

License Agreement 
 
Please read the following terms and conditions carefully before using this software. Your use of this software indicates your 
acceptance of this license agreement. If you do not agree with the terms of this license, you must remove this software from your 
storage devices and cease to use the product. 
 
Copyright 
This software is copyrighted 1999-2003 by TamoSoft, Inc. CommView is a registered trademark of TamoSoft, Inc. The use and 
copyright of this software are governed by international copyright treaties. TamoSoft, Inc. retains full title and rights to this 
software and documentation, and in no way does the license granted diminish the intellectual property rights of TamoSoft, Inc. You 
must not redistribute the registration codes provided--on paper, electronically, or in any other form. 
 
Evaluation Version 
This is not free software. You are hereby licensed to use this software for evaluation purposes without charge for a period of 30 
days. Using this software after the evaluation period violates copyright laws and may result in severe civil and criminal penalties.  
 
Registered (Licensed) Version 
One registered copy of this software may be used by a single person who uses the software personally on one or more computers, 
or it may be installed on a single workstation used non-simultaneously by more than one person, but not both. This software may 
be installed on a network server, provided that a separate, appropriate license to use this software has been granted by TamoSoft, 
Inc. for each computer terminal having access to this software.  
 
Upgrades 
This Agreement does not grant you any right to any enhancement, updates, or upgrades for this software (collectively, "upgrades"). 
TamoSoft, Inc. may or may not, at its sole discretion, offer such upgrades to licensed users. TamoSoft, Inc. does not warrant that 
such upgrades will be available, or that such upgrades will offer any enhancements in compatibility with the latest industry 
standards, including, but not limited to, new hardware devices, network protocols, or encryption algorithms. 
 
Disclaimer 
TAMOSOFT, INC. DOES NOT WARRANT THAT THE PRODUCT IS ERROR FREE. THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.  IN NO EVENT WILL TAMOSOFT, INC. BE LIABLE TO YOU FOR 
ANY DAMAGES, INCLUDING INCIDENTAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND 
IT, AND AGREE TO BE BOUND BY ITS TERMS.  
 
Governing Law 
This Agreement will be governed by the laws of the Republic of Cyprus. 
 
Distribution 
This software may be distributed freely in its original unmodified and unregistered form. The distribution must include all files of its 
original distribution. Distributors may not charge any money for it. Anyone distributing this software for any kind of remuneration 
must first contact us for authorization. 
 
Other Restrictions 
You may not modify, reverse engineer, decompile or disassemble this software in any way, including changing or removing any 
messages or windows.  
 
Windows is a registered trademark of Microsoft Corporation. All other trademarks and service marks are the property of their respective owners. 



 
Using the Program 
 
Driver Installation 
 
CommView for WiFi is a tool for monitoring wireless 802.11b networks. To use this product, you must have a compatible wireless 
adapter. To enable the monitoring features of your wireless adapter, you will need to use a special driver that comes with this 
product. If you have already installed your adapter, you will have to replace the adapter's original driver with the new one. If you 
have not installed the adapter into your computer, you will have to install the adapter, using the driver that comes with this 
product. This brief manual will guide you through the driver installation process. 
 
Please note that once the driver has been replaced, your adapter will be put in passive, monitoring mode and will no longer be able 
to communicate with other wireless hosts or access points. To restore the standard functions of your adapter, you would need to 
roll back/return to the original adapter's driver supplied by the vendor. 
 
If you would like to preserve your wireless connectivity while using this product, consider installing two wireless adapters, one of 
which would be used for monitoring, while the other would perform standard network functions. 
 
Prior to installing the new driver for your wireless adapter, be sure that your adapter is compatible with this product. The following 
adapters have been tested and are compatible with CommView for WiFi: 
 

3Com 3CRWE7373 AirConnect Wireless LAN Card 
3Com 3CRWE737A AirConnect Wireless LAN Card 
3Com 3CRWE777A AirConnect Wireless LAN PCI Card 
Actiontec 802.11b Wireless PC Card 
Actiontec MiniPCI 802.11b Wireless Adapter 
Actiontec PCI 802.11b Wireless Adapter 
Belkin F5D6000 Wireless PCI Network Adapter 
Belkin F5D6020 Wireless PCMCIA Network Adapter 
BENQ AWL100 Wireless LAN PCMCIA Adapter 
Cisco Systems 340 Series PCI Wireless LAN Adapter * 
Cisco Systems 340 Series PCMCIA Wireless LAN Adapter * 
Cisco Systems 350 Series PCI Wireless LAN Adapter * 
Cisco Systems 350 Series PCMCIA Wireless LAN Adapter * 
Compaq WL100 11Mbps Wireless LAN PC Card 
Compaq WL200 11Mbps Wireless LAN PCI Card 
Corega PCCL-11 Wireless LAN PCMCIA Card * 
Dell TrueMobile 1150 Series Card 
Dell TrueMobile 1150 Series Mini PCI Card 
DemarcTech Reliawave 802.11b Wireless PC Card 
D-Link DWL-500 Wireless PCMCIA Adapter 
D-Link DWL-520 Wireless PCI Adapter 
D-Link DWL-650 Wireless PCMCIA Adapter 
D-Link DWL-650H 11Mbps WLAN PC Card 
Ericsson DSSS Wireless LAN PC Card 
Ericsson DSSS Wireless LAN PCI Card 
Fujitsu IEEE 802.11 Wireless LAN/CF Card (3V) 
Fujitsu IEEE 802.11 Wireless LAN/CF Card (5V) 
Fujitsu MiniPCI Wireless LAN Card 
Fujitsu PCI Wireless LAN Card 
Intel PRO/Wireless 2011 LAN PC Card 
Intel PRO/Wireless 2011 LAN PCI Card 
LinkSys WPC11 Wireless PC Card v.3 
Lucent ORiNOCO Card 
Microsoft MN-520 Wireless Notebook Adapter 
NetGear MA301 Wireless PCI Adapter 
NetGear MA311 Wireless PCI Adapter 
NetGear MA401 Wireless PC Card 
NetGear MA701 Wireless CF Card 
Nortel Networks e-mobility 802.11b Wireless LAN PC Card 
Nortel Networks e-mobility 802.11b Wireless LAN PCI Card 
Nortel Networks e-mobility 802.11b WLAN PC Card 
Planet WL-3550 Wireless PC Card 
Repotec IEEE802.11b WLAN PCI Card v2.5 
Repotec RP-2061 11Mbps Wireless LAN PCMCIA Card 
Repotec RP-2064 Wireless PCI Card Reader Ver.1.5 
Siemens I-Gate 11M PC Card 
Symbol LA4111 Spectrum24 Wireless LAN PC Card 
Symbol LA4113 Spectrum24 Wireless LAN PCI Card 
Symbol Spectrum24 802.11b Wireless LAN PCI Card 
Symbol Spectrum24 LA-4100 Series Wireless LAN PC Card 
TrendWare TEW-PC16 Wireless PCMCIA Network Card 
U.S. Robotics Wireless 802.11b PC Card 



U.S. Robotics Wireless 802.11b PCI Adapter 
Xircom Wireless Ethernet Adapter 
Z-Com LANEscape/XI-300 PC Card 

 
* Please read important technical notes about these cards. 
 
If your PCMCIA or PCI card (sorry, no USB at this time) is not on this list, please click read the FAQ chapter. 
 
For detailed driver installation instructions, please launch the program, click Help => Driver Installation Guide in the program's 
menu, and scroll down to the bottom of the window. 
 

http://www.tamos.com/products/commwifi/technotes.php


 
Overview 
 
The program interface consists of five tabs that allow you to view data and perform various actions with captured packets. To start 
capturing packets, click on the Start Capture button or select File = > Start Capture from the menu.  
 
Main Menu 
 
File 
Start/Stop Capture – starts/stops capturing packets. 
Suspend/Resume Packet Output – stops/resumes the real-time packet output on the 2nd tab. 
Save IP Statistics As – allows you to save the contents of the IP Statistics tab as a HTML report. 
Save Packet Log As – allows you to save the contents of the Packets tab in different formats. Use the Logging tab for advanced 
saving options. 
Log Viewer – opens a new Log Viewer window. 
Clear IP Statistics – clears the IP Statistics table (1st tab). 
Clear Packet Buffer – clears the contents of the program's buffer and the packet list (2nd tab). 
Performance Data – displays the program's performance statistics: the number of packets captured and dropped by the device 
driver.  
Exit – closes the program. 
 
Search 
Find Packet – shows a dialog that allows you to find packets matching a specific text. 
Go to Packet Number - shows a dialog that allows you to jump to a packet with the specified number. 
 
View 
Statistics – shows a window with data transfer and protocol distribution statistics. 
Port Reference – shows a window with port reference information. 
Log Directory – opens the directory to which logs are saved by default. 
IP Statistics Columns – shows/hides the IP Statistics tab columns.  
Packets Columns – shows/hides the Packets tab columns. 
 
Tools 
Reconstruct TCP Session – allows you to reconstruct a TCP session starting from the selected packet; it opens a window that 
displays the entire conversation between two hosts. 
NIC Vendor Identifier – opens a window where you can identify a network adapter vendor by MAC address. 
Scheduler – allows you to add or remove scheduled capturing tasks. 
 
Settings 
Fonts – shows the submenu for setting the fonts of the interface elements. 
WEP Keys – opens a window that allows you to enter WEP keys. 
MAC Aliases – brings up a window where you can assign easy-to-remember aliases to MAC addresses. 
IP Aliases – brings up a window where you can assign easy-to-remember aliases to IP addresses. 
Options – brings up the Options window where additional advanced program options can be set. 
Language – allows you to change the interface language. Be sure to restart the program once you've changed the language. 
 
 
Rules 
Capture Data Packets – check or uncheck this item to enable/disable capturing of packets of the type "Data". 
Capture Management Packets – check or uncheck this item to enable/disable capturing of packets of the type "Management". 
Capture Control Packets – check or uncheck this item to enable/disable capturing of packets of the type "Control". 
Save Current Rules As – allows you to save current rules configuration to a file. 
Load Rules From – allows you to load a previously saved rules configuration from a file. 
Reset All – clears all existing rules (if any). 
 
Help 
Contents – launches CommView help.  
Search For Help On …  – shows CommView help index. 
Driver Installation Guide …  – shows detailed driver installation instructions. 
About – shows information about the program. 
 
 
Almost every element of the interface has a context-sensitive menu that can be invoked by clicking on the right mouse button, and 
many commands are available only through these menus. 
 
The first tab is used for displaying detailed information about your computer's network connections (IP protocol only). For more 
information see IP Statistics. 
 
The second tab is used for viewing captured network packets and displaying detailed information about a selected packet. For more 
information see Packets. 
 
The third tab allows you to save captured packets to files. For more information see Logging. 
 



The fourth tab is for configuring rules that allow you to capture/ignore packets based on various criteria, such as IP address or port 
number. For more information see Rules. 
 
The fifth tab allows you to create alarms that can notify you about important events, such as suspicious packets, high bandwidth 
utilization, unknown addresses, etc. For more information see Alarms. 
 
You can change some of the settings, such as fonts, colors, and buffer size by selecting Settings from the menu. For more 
information see Setting Options. 
 



 
Scanner 
 
The Scanner window allows you to scan the air for WiFi signals and selecting a channel to monitor. To start scanning, just click on 
the Start Scanning button. The scanning process is cyclic, i.e. the program will "listen" for signals on the first channel, then switch 
to the next channel, and so forth, until it reaches the last channel, after which a new scanning cycle will begin. The scanning 
process will not stop until Stop Scanning is clicked. To clear the data that have been collected, click Reset. To save the scanning 
report in HTML format, click Save …. When you are done with scanning and/or if you know the channel on which you want the 
program to capture packets, select a channel from the Channel drop-down list and click Capture. 
 
The following scanning options are available: 
 

 
 

Reset data after each cycle – check this box if you would like the program to clear all the data it has collected before beginning 
a new scanning cycle. This option has both drawbacks and advantages. The advantage is that resetting data will give you the most 
up-to-date picture of the ether. For example, if a certain station no longer sends data, it will not show up on the list again. 
However, the drawback is that if a certain station does not send data actively, e.g. it does so just a few times per minute, the 
scanner may not "notice" the station each time it scans a certain channel. Furthermore, this station will be removed from the list. 

Show data in main window while scanning – check this box if you would like the program to display the packets being 
captured during scanning in the main program's window (on the Packets and IP Statistics tabs). If this box is not checked, the 
packets that are captured while the scanner is working will not be displayed or logged anywhere. 

Hide wired hosts – check this box if you would like the program to show only wireless hosts and access points. If this box is not 
checked, the scanner will show both wireless and wired hosts in the segment being scanned. Note that enabling this option may 
sometimes hide even wireless hosts, as the program needs to capture several data packets to determine if a host is wired or 
wireless. 

Seconds per channel – determines the time interval the scanner will listen for data on each of the channels being scanned. 

Channels to scan  – allows you to select the channels to be scanned. You need to select at least one channel. Depending on your 
country, your wireless network adapter may not support all the 14 channels specified in the IEEE 802.11b standard. If your card 
does not support a channel, the corresponding box will be disabled.  

 
 



 
IP Statistics 
 
This tab is used for displaying detailed information about WLAN connections (IP protocol only). To start capturing packets, select 
File = > Start Capture in the menu, or click on the corresponding button on the toolbar. Please note that this tab will not be 
populated unless the program is capable of decrypting WEP-encrypted WLAN traffic. If your WLAN uses WEP encryption, all the 
data packets being sent are encrypted, and it is impossible to obtain information about IP address unless you have entered the 
correct WEP key(s). To enter your WEP key(s), select Settings => WEP Keys in the menu. 
 
 

 
 
The meaning of the table columns is explained below: 
 
Source IP, Destination IP – shows the pair of IP addresses between which the packets are being sent. 
In – shows the number of packets received. 
Out – shows the number of packets sent. 
Sessions – shows the number of established TCP/IP sessions. If no TCP connections were established (connections failed, or the 
protocol is UDP/IP or ICMP/IP), this value is zero.   
Ports – lists the remote computer's ports used during the TCP/IP connection or connection attempt. This list can be empty if the 
protocol is not TCP/IP. Ports can be displayed either as numeric values or as the corresponding service names. For more 
information see Setting Options. 
Hostname – shows the remote computer's hostname. If the hostname cannot be resolved, this column is empty. 
Bytes – shows the number of bytes transmitted during the session.  
Last packet – shows the time of the last packet sent/received during the session.  
 
You can show or hide individual columns by clicking on the corresponding items in the View =>IP Statistics Columns menu. 
 
 
Menu Commands 
 
Right-clicking on the IP Statistics list brings up a menu with the following commands: 
 
Copy  – copies the local IP address, remote IP address, or hostname to the clipboard. 
Show All Ports – displays a window with the complete list of ports used in communicating between the selected pair of IP 
addresses. This is useful when many ports were used, and they don't fit into the corresponding column. 
Data Transfer – displays a window with information on the data transfer volume between the selected pair of IP addresses and 
the time of the last packet. 
Jump To – allows you to quickly jump to the first/last packet with the selected source/destination IP address; the program will 
display the Packets tab and set the mouse cursor to the packet that matches the criterion.  
SmartWhois – sends the selected remote IP address to SmartWhois, if it is installed on your system. SmartWhois is a stand-alone 
application developed by our company capable of obtaining information about any IP address or hostname in the world. It 
automatically provides information associated with an IP address, such as domain, network name, country, state or province, city. 
The program can be downloaded from our site. 
Create Alias -- brings up a window where you can assign an easy-to-remember aliases to the selected IP address. 
Save IP Statistics As – allows you to save the contents of the IP Statistics tab as a HTML report. 
Clear IP Statistics – clears the table. 
More Statistics  -- shows a window with data transfer and protocol distribution statistics. 
 

http://www.tamos.com/download/main/


 
Packets 
 
This tab is used for listing all captured network packets and displaying detailed information about a selected packet. 
 
 

 
 
The top table displays the list of captured packets. Use this list for selecting a packet that you want to have displayed and 
analyzed. When you select a packet by clicking on it, other panes show information about the selected packet. 
 
The meaning of the table columns is explained below: 
 
No – a unique packet number.  
Protocol – shows the packet's protocol.  
MAC Addresses – shows the source and destination MAC addresses. 
IP Addresses – shows the source and destination IP addresses (where applicable). 
Ports – shows the source and destination ports (where applicable). Ports can be displayed either as numeric values or as the 
corresponding service names. For more information, see Setting Options. 
Time / Delta – shows the packet's absolute or delta time. Delta time is the difference between the absolute times of the last two 
packets. You can switch from absolute to delta time by clicking View =>Packets Columns =>Show Time As.  
Size – shows packet size in bytes. This column is not visible by default. 
Signal – shows signal strength and data transfer rate. 
More Details – shows additional information for some packet types. 
 
Individual columns can be shown or hidden by clicking on the corresponding items in the View =>Packets Columns menu. The 
packet output can be suspended by clicking File =>Suspend Packet Output. In the Suspended mode, the packets are being 
captured, but not displayed, on the Packets tab. This mode is useful when you are interested only in the statistics rather than 
individual packets. To resume real-time packets display, click File =>Resume Packet Output.  
 
The middle pane displays the raw contents of the packet, both in hexadecimal notation and as plain text. In the plain text, non-
printable characters are replaced with dots. 
 
The bottom pane displays decoded packet information for the selected packet. This information includes vital data that can be 
used by network professionals. Right-clicking on the pane invokes the context menu that allows you to collapse/expand all the 
nodes or to copy the selected or all nodes. You can change the position of the decoder window by clicking on one of the three 
buttons at the pane edge (you can have a bottom-, left-, or right-aligned decoder window). 
 
 
Menu Commands 
 
Right-clicking on the packet list brings up a menu with the following commands: 
 
Reconstruct TCP Session – allows you to reconstruct a TCP session starting from the selected packet; it opens a window that 
displays the entire conversation between two hosts. 
Create Alias -- brings up a window where you can assign an easy-to-remember aliases to the selected MAC or IP address. 
Copy Address – copies the source MAC address, destination MAC address, source IP address, or destination IP address to the 
clipboard. 
Copy Packet – copies the raw data of the selected packet to the clipboard. 



Save Packet(s) As – saves the contents of the selected packet(s) to a file. The Save As dialog allows you to select the format to 
be used when saving data from the drop-down list. 
Clear Packet Buffer – clears the contents of the program's buffer. The packet list will be cleared, and you will not be able to view 
the packets previously captured by the program. 
Decode As – for TCP and UDP packets, allows you to decode supported protocols that use non-standard ports.  For example, if 
your SOCKS server runs on port 333 rather than 1080, you can select a packet that belongs to the SOCKS session and use this 
menu command to make CommView decode all packets on port 333 as SOCKS packets. Such protocol-port reassignments are not 
permanent and will last only until the program is closed. Note that you cannot override standard protocol-port pairs, e.g. you 
cannot make CommView decode packets on port 80 as TELNET packets.  
 
You can also drag-and-drop selected packet(s) to the desktop. 



 
Logging 
 
This tab is used for saving captured packets to a file on the disk. CommView saves packets in its own format with the .CCF 
(CommView Capture Files) extension. You can open and view these files at any time using Log Viewer, or you can just double-click 
on any CCF file to have it loaded and decoded. 
 
Save Log 
 
Use this frame to save manually the captured packets to a file. You can either save all packets currently stored in the buffer or save 
only a part of them within a given range. The To and From fields allow you to set the necessary range based on the packet 
numbers as shown on the Packets tab. Click Save As … to select a file name. 
 
Auto-saving 
 
Check this box to have the program automatically save captured packets as they arrive. Use the Maximum directory size field to 
limit the total size of the capture files stored in the Log Directory. If the total size of the capture files exceeds the limit, the 
program automatically deletes the oldest files in the directory. To change the default Log Directory, click on the Save files to box 
and select a different folder. Packets are logged in chunks, 500 packets in each file. If you prefer to have all files generated during 
the current capturing session concatenated into a single file, check the Concatenate files when capturing is stopped box. This 
will make the program create a single file when you stop capturing. 
 
 A log file with 500 packets is approximately 500 kilobytes in size. 
 
IMPORTANT: If you want to have an important capture file stored for a long time, don't keep it in the default Log Directory: there is 
a chance it will be automatically deleted as new files are being saved. Move the file to a different folder to preserve it. 
 
Please note that the program doesn't save each packet individually immediately upon arrival. Packets are saved in groups, 500 
each. It means that if you view the log file in real time, it may not contain the last 500 packets. To make the program immediately 
dump the buffer to the log file, either click Stop Capture or uncheck the Auto-saving box. 
 
Log Management 
 
Use this frame to concatenate manually multiple CCF files into a single, larger file by clicking on the Concatenate Logs button, or 
split CCF files that are too large in size into smaller chunks by clicking on the Split Logs button. The program will then guide you 
through the process, and you will be able to enter the desired size of the output files. 



 
Viewing Logs 
 
Log Viewer is a tool for viewing and exploring capture files created by CommView and several other packet analyzers. It has the 
functionality of the Packets tab of the main program window, but unlike the Packets tab, Log Viewer displays packets loaded 
from the files on the disk rather than the packets captured in real time. 
 
To open Log Viewer, click File => Log Viewer in the program's main menu, or just double-click on any CommView capture file 
that you have previously saved. You can open as many Log Viewer windows as you wish, and each of them can be used for 
exploring one or several capture files. 
 
Log Viewer can be used for exploring capture files created by other packet analyzers and personal firewalls. The current version can 
import files in the Network Instruments Observer®, Network Associates Sniffer® for DOS/Windows, Microsoft® NetMon, 
WildPackets EtherPeek™ and AiroPeek™, and Tcpdump (libcap) formats. These formats are also used by a number of 3rd-party 
applications.   Log Viewer is capable of exporting packet data by creating files in the Network Instruments Observer®, Network 
Associates Sniffer® for DOS/Windows, Microsoft® NetMon, WildPackets EtherPeek™ and AiroPeek™, and Tcpdump (libcap) 
formats, as well as the native CommView format. 
 
Using Log Viewer is similar to using the Packets tab of the main window; please refer to the Packets chapter if you need detailed 
information. 
 
Log Viewer Menu 
 
File 
Load CommView Logs – opens and loads one or several CommView capture files. 
Import Logs – allows you to import capture files created by other packet analyzers. 
Export Logs – allows you to export the displayed packets to capture files in several formats. 
Clear Window – clears the packet list. 
Close Window – closes the window. 
 
Search 
Find Packet – shows a dialog that allows you to find packets matching a specific text. 
Go to Packet Number - shows a dialog that allows you to jump to a packet with the specified number. 
 
Rules 
Apply – applies your current rule set to the packets displayed in Log Viewer. As a result, when you use this command the program 
will delete the packets that don't match the current rule set. Note that this won't modify the file on the disk. 
From File … - does the same as the Apply command, but allows you to use a rule set from a previously saved .RLS file rather 
than the current rule set. 
 
Observer® and Sniffer® are registered trademarks of Network Instruments, LLC and Network Associates, Inc. respectively. 
 



 
Rules 
 
CommView allows you to set two types of rules.  
 
The first type (wireless rules) allows you to filter packets based on the wireless packet type: Data, Management, and Control 
packets. To turn capturing of these packet types on or off, use the Rules command of the program's menu, or the corresponding 
toolbar buttons.  
 
The second type (conventional rules) allows you to filter packets based on many criteria, such as port number or MAC address. 
To use this type of rules, switch to the Rules tab of the program's main window. If one or more rules are set, the program filters 
packets based on the set rules and displays only the packets that comply with these rules. If a rule is set, the name of the 
corresponding tab is displayed in bold font. 
 
The program's status bar shows the number of conventional rules that are currently active. Note that it does not show the number 
of active wireless rules, as the state of the toolbar buttons (up or down) clearly indicate if any of the wireless rules are on or off. 
Also note that wireless rules have precedence over conventional rules. Any captured packet must first pass the wireless rules before 
any further processing takes place. If, for example, none of the three wireless rules toolbar buttons is pressed, the program will not 
display any packets. 
 
You can save your rules configuration(s) to a file and load them by using the Rules command of the program's menu. 
 
Since WLAN traffic can often generate a high number of packets, it is recommended that you use rules to filter out unnecessary 
packets. This can considerably reduce the amount of system resources consumed by the program. If you want to enable/disable a 
rule, select the appropriate tab on the left side of the window (e.g. IP Addresses or Ports), and check or uncheck the box 
describing the rule (Enable IP Address rules or Enable port rules). There are seven types of rules that can be used: 
 
 



Protocols & Direction 
 
Allows you to ignore or capture packets based on Ethernet (Layer 2) and IP (Layer 3) protocols, as well as on packet direction.  
 
 

 
 
This example shows how to make the program capture only inbound and outbound ICMP and UDP packets. All other packets in the 
IP family will be ignored; all pass-through packets will be ignored also. 
 
 



MAC Addresses 
 
Allows you to ignore or capture packets based on MAC (hardware) addresses. Enter a MAC address in the Add Record frame, 
select the direction (From, To, or Both), and click Add MAC Address. The new rule will be displayed. Now you can select the 
action to be taken when a new packet is processed: the packet can be either captured or ignored. You can also click on the MAC 
Aliases button to get the list of aliases; double-click on the alias you would like to add, and the corresponding MAC address will 
appear in the input box. 
 

 
 
This example shows how to make the program ignore packets that come from 0A:DE:34:0F:23:3E. All packets that come from other 
MAC addresses will be captured. 
 
 



IP Addresses 
 
Allows you to ignore or capture packets based on IP addresses. Enter an IP address in the Add Record frame, select the direction 
(From, To, or Both), and click Add IP Address. You can use wildcards to specify blocks of IP addresses. The new rule will be 
displayed. Now you can select the action to be taken when a new packet is processed: the packet can be either captured or 
ignored. You can also click on the IP Aliases button to access the list of aliases; double-click on the alias you would like to add, and 
the corresponding IP address will appear in the input box. 
 

 
 
This example shows how to make the program capture the packets that go to 63.34.55.66, go to and come from 207.25.16.11 and 
come from all addresses between 194.154.0.0 and 194.154.255.255. All packets that come from other addresses or go to other 
addresses will be ignored. Since IP addresses are used in the IP protocol, such configuration will automatically make the program 
ignore all non-IP packets. 
 
 



Ports 
 
Allows you to ignore or capture packets based on ports. Enter a port number in the Add Record frame, select the direction (From, 
To, or Both), and click Add Port. The new rule will be displayed. Now you can select the action to be taken when a new packet is 
processed: the packet can be either captured or ignored. You can also press the Port Reference button to get a list of all known 
ports; double-click on the port you would like to add and its number will appear in the input box. You can also click on the Port 
Reference button to get a list of all known ports; double-click on the port you would like to add and its number will appear in the 
input box. Ports can also be entered as text; for example, you can type in http or pop3, and the program will convert the port name 
to the numeric value. 
 

 
 
This example shows how to make the program ignore packets that come from port 80 and go to and come from port 137. This rule 
will prevent CommView from displaying inbound HTTP traffic, as well as inbound and outbound NetBIOS Name Service traffic. All 
packets coming to and from other ports will be captured.  
 
 



TCP Flags 
 
Allows you to ignore or capture packets based on TCP flags. Check a flag or a combination of flags in the Add Record frame, and 
click Add Flags. The new rule will be displayed. Now you can select the action to be taken when a new packet with the entered 
TCP flags is processed: the packet can be either captured or ignored. 
 

 
 
This example shows how to make the program ignore TCP packets with the PSH ACK flag. All packets with other TCP flags will be 
captured. 
 
 



Text 
 
Allows you to capture packets that contain certain text. Enter a text string in the Add Record frame, select the type of entered 
information  (As String or As Hex), and click Add Text. The new rule will be displayed. You can enter text either as a string (self-
explanatory), or as a hexadecimal value. The latter method should be used when you want to enter non-printable characters: just 
type hexadecimal character values separated by spaces, as shown below. Now you can select the action to be taken when a new 
packet is processed: the packet can be either captured or ignored. 
 

 
 
This example shows how to make the program capture only the packets that contain either "GET" or the 01 02 03 04 hex data. 
Check the Case sensitive box if you want the rules to be case sensitive. All other packets that do not contain the text mentioned 
above will be ignored. 
 
Advanced 
 
Advanced rules are the most powerful and flexible rules that allow you to create complex filters using Boolean logic. For the detailed 
help on using advanced rules, please refer to the Advanced Rules chapter. 
 
 



 
Advanced Rules 
 
Advanced rules are the most powerful and flexible rules that allow you to create complex filters using Boolean logic. Using advanced 
rules requires a basic understanding of mathematics and logic, but the rules syntax is rather easy to understand. 
 

 
 
Overview 
 
To add a new rule, you should enter an arbitrary name in the Name field, select the action (Capture/Ignore), enter a Formula 
using the syntax described below, and click Add/Edit. Your new rule will be added to the list and become active immediately. You 
can add as many rules as you wish, but only those rules that have a checked box next to the rule name are active currently. You 
can activate/deactivate rules by checking/unchecking the corresponding boxes or completely delete selected rules using the Delete 
button. If more than one rule is active, you can evaluate the resulting combined rule by clicking Evaluate. Please note that multiple 
active rules are combined using the logical OR operator, e.g. if you have three active rules, RULE1, RULE2, and RULE3, the resulting 
rule is RULE1 OR RULE2 OR RULE3. 
 
You can use advanced rules in conjunction with the basic rules described in the previous chapter, however if you feel comfortable 
with Boolean logic, it's a good idea to use advanced rules only, as they offer much more flexibility. Basic rules are combined with 
advanced rules using the logical AND operator. 
 
Syntax Description 
 
dir – Packet direction. Possible values are in (inbound), out (outbound), and pass (pass-through). This keyword is for compatibility 
with the standard, non-wireless edition of CommView only. In CommView for WiFi, there are no inbound or outbound packets, 
because your adapter does not participate in data exchange and only passively monitors pass-through packets. 
 
etherproto – Ethernet protocol, the 13th and 14th bytes of the packet. Acceptable values are numbers (e.g. etherproto=0x0800 for 
IP) or common aliases (e.g. etherproto=ARP, which is equivalent to 0x0806).  
 
ipproto – IP protocol. Acceptable values are numbers (e.g. ipproto!=0x06 for TCP) or commonly used aliases (e.g. ipproto=UDP, 
which is equivalent to 0x11). 
 
smac – Source MAC address. Acceptable values are MAC addresses in hex notation (e.g. smac=00:00:21:0A:13:0F) or user-defined 
aliases. 
 
dmac – Destination MAC address.  
 
sip – Source IP address. Acceptable values are IP addresses in dotted notation (e.g. sip=192.168.0.1), IP addresses with wildcards 
(e.g. sip!=*.*.*.255),  network addresses with subnet masks (e.g. sip=192.168.0.4/255.255.255.240 or sip=192.168.0.5/28), IP 
ranges (e.g. sip from 192.168.0.15 to 192.168.0.18 or sip in 192.168.0.15 .. 192.168.0.18  ), or  user-defined aliases. 
 
dip -  Destination IP address. 
 
sport – Source port for TCP and UDP packets. Acceptable values are numbers (e.g. sport=80 for HTTP), ranges (e.g. sport from 20 
to 50  or sport in 20..50 for any port number between 20 and 50) or the aliases defined by your operating system  (e.g. sport=ftp, 
which is equivalent to 21). For the list of aliases supported by your OS click View => Port Reference. 
 
dport – Destination port for TCP and UDP packets.  
 



flag – TCP flag.  Acceptable values are numbers (e.g. 0x18 for PSH ACK) or one or several of the following characters:  F (FIN), S 
(SYN), R (RST), P (PSH), A (ACK), and U (URG), or the has keyword, which means that the flag contains a certain value. Usage 
examples: flag=0x18, flag=SA, flag has F. 
 
size – Packet size. Acceptable values are numbers (e.g. size=1514) or ranges (e.g. size from 64 to 84 or size in 64..84 for any size 
between 64 and 84). 
 
str – Packet contents. Use this function to indicate that the packet must contain a certain string. This function has three 
arguments: string, position, and case sensitivity. The first argument is a string, e.g. 'GET'. The second argument is a number that 
indicates the string position (offset) in the packet. The offset is zero-based, i.e. if you're looking for the first byte in the packet, the 
offset value must be 0. If the offset is not important, use  –1. The third argument indicates the case-sensitivity and can be either 
false (case-insensitive) or true (case-sensitive). The second and third arguments are optional; if omitted, the offset defaults to –1 
and the case-sensitivity defaults to false. Usage examples: str('GET',-1,false), str('GET',-1), str ('GET'). 
 
hex - Packet contents. Use this function to indicate that the packet must contain a certain hexadecimal byte pattern. This function 
has two arguments: hex pattern and position. The first argument is a hex value, e.g. 0x4500. The second argument is a number 
that indicates the pattern position (offset) in the packet. The offset is zero-based, i.e. if you're looking for the first byte in the 
packet, the offset value must be 0. If the offset is not important, use  –1. The second argument is optional; if omitted, the offset 
defaults to –1. Usage examples:  hex(0x04500, 14) , hex(0x4500, 0x0E), hex (0x010101). 
 
The keywords described above can be used with the following operators: 
 
and - Boolean conjunction. 
or  - Boolean disjunction.   
not - Boolean negation.  
=  - Arithmetic equality.  
!= - Arithmetic inequality. 
<> - Same as above. 
> - Arithmetic greater-than. 
< - Arithmetic less-than. 
( ) – parenthesis, control operator precedence rules. 
 
All numbers can be in decimal or hexadecimal notation. If you want to use the hexadecimal notation, the number must be preceded 
by 0x, i.e. you can use either 15  or 0x0F.  
 
Examples 
 
Below you will find a number of examples illustrating the rules syntax. Each rule is followed by our comments about what the rule 
does. The rules are shown in red. The comments are separated from the actual rule by two slashes. 
 

• (smac=00:00:21:0A:13:0E or smac=00:00:21:0A:13:0F) and etherproto=arp // Captures ARP packets sent by two 

computers, 00:00:21:0A:13:0E and 00:00:21:0A:13:0F. 

• ipproto=udp and dport=137 // Captures UDP/IP packets sent to the port number 137. 

• dport=25 and str('RCPT TO:', -1, true) // Captures TCP/IP or UDP/IP packets that contain "'RCPT TO:" and where the 

destination port is 25. 

• not (sport>110) // Captures everything except the packets where the source port is greater than 110 

• (sip=192.168.0.3 and dip=192.168.0.15)  or (sip=192.168.0.15 and dip=192.168.0.3) // Captures only the IP packets 

being sent between two machines, 192.168.0.3 and 192.168.0.15. All other packets are discarded. 

• ((sip from 192.168.0.3 to 192.168.0.7) and (dip = 192.168.1.0/28)) and (flag=PA) and (size in 200..600) // Captures TCP 

packets the size of which is between 200 and 600 bytes coming form the IP addresses in the 192.168.0.3 - 192.168.0.7 

range, where destination IP address is in the 192.168.1.0/255.255.255.240 segment, and where the TCP flag is PSH ACK. 

• Hex(0x0203, 89) and (dir<>in) // Captures the packets that contain 0x0203 at the offset 89, where the packet direction 
is not inbound. 

 
 



 

Alarms 
 
This tab allows you to create alarms that can notify you about important events, such as suspicious packets, high bandwidth 
utilization, unknown addresses, etc. Alarms are very useful in a situation were you need to watch the network for some suspicious 
events, for example distinctive byte patterns in captured packets, port scans, or unexpected hardware device connections.  
 
Alarms are managed using the alarm list shown below: 
 

 
 
Each line represents a separate alarm, and the check box next to the alarm name indicates if the alarm is currently active. When an 
alarm is triggered, the check mark disappears. To reactivate a deactivated alarm, check the box next to its name. To disable all 
alarms, uncheck the Enable alarms box. To add a new alarm or edit or delete an existing one, use the buttons to the right of the 
alarm list. The E-mail Setup button should be used for entering information about your SMTP server if you plan to use e-mail 
notification options (see below). 
 
The alarm setup window is shown below: 
 

 
 
The Name field should be used for describing the alarm function. Check the Enabled box if you want the alarm that you're 
adding/editing to be activated once you've finished its setup. This check box is equivalent to the one shown in the alarms list. The 
Alarm Type frame allows you to select one of the four alarm types: 
 

• Packet occurrence: The alarm will be triggered once CommView has captured a packet that matches the given formula. 
The formula syntax is the same as the syntax used in Advanced Rules and is described in the Advanced Rules chapter in 
detail. 

 
• Bytes per second: The alarm will be triggered once the number of bytes per second has exceeded the specified value. 

Note that you should enter the value in bytes, so if you would like to have the alarm triggered when the data transfer 
rate exceeds 1Mbyte per second, the value you should enter is 1000000.  

 



• Packets per second: The alarm will be triggered once the number of packets bytes per second has exceeded the 
specified value.  

 
• Unknown MAC address: The alarm will be triggered once CommView has captured a packet with an unknown source 

or destination MAC address. Use the Configure button to enter known MAC addresses. This alarm type is useful for 
detecting new, unauthorized hardware devices connected to your WLAN. 

 
• Unknown IP address: The alarm will be triggered once CommView has captured a packet with an unknown source or 

destination IP address. Use the Configure button to enter known IP addresses. This alarm type is useful for detecting 
unauthorized IP connections behind a corporate firewall. 

 
The Events needed to trigger field allows you to specify the number of times the expected event must occur before the alarm is 
triggered. For example, if you specify the value of 3, the alarm will not be triggered until the even occurs three times. If you edit an 
existing alarm, the internal event counter will be reset.  
 
The Times to trigger this alarm field allows you to specify the number of times your alarm may be triggered before the 
deactivation. By default, this value equals 1, so the alarm will be disabled after the first even occurrence. By increasing this value, 
you will make CommView trigger the alarm multiple times.  If you edit an existing alarm, the internal trigger counter will be reset.  
 
The Action frame allows you to select the actions to be performed when the alarm event occurs. The following actions are 
available: 
 

• Display message: Shows a non-modal message box with the specified text. 
 

• Play sound: Plays the specified WAV file.  
 

• Launch application: Runs the specified EXE or COM file. Use the optional Parameters field to enter command line 
switches. 

 
• Send e-mail to: Sends e-mail to the specified e-mail address. You MUST configure CommView to use your SMTP server 

prior to sending e-mail. Use the E-mail Setup button next to the alarm list to enter your SMTP server settings and send 
a test e-mail message. Usually, an e-mail message can also be used to send alerts to your instant messaging application, 
cell phone, or pager. For example, to send a message to an ICQ user, you should enter the e-mail address as 
ICQ_USER_UIN@pager.icq.com, where ICQ_USER_UIN is the user's unique ICQ identification number, and allow 
EmailExpress messages in the ICQ options. Please refer to your instant messenger documentation or cell phone operator 
for more information. 

 
• Enable capturing rules: Enables Advanced Rules; you should enter the rule name(s). If multiple rules must be enabled, 

separate them with a comma or semicolon. 
 

• Disable other alarms: Disables other alarms; you should enter the alarm name(s). If multiple alarms must be enabled, 
separate them with a comma or semicolon. 

 
• Start logging: Turns on auto-saving (see the Logging chapter); CommView will start dumping packets to the hard drive.  

 
• Stop logging: Turns off auto-saving.  

 
 
Click OK to save the settings and close the alarm setup dialog. 
 
All the events and actions related to the alarms will be listed in the Event Log window below the alarm list. 
 



 

WEP Keys 
 
The WEP Keys window allows WEP keys to be entered for the decryption of captured packets. The 802.11b standard allows you to 
use up to four keys, so you can specify one, two, three, or four keys. The key length drop-down list allows you to select the key 
length. Supported lengths are 64, 128, and 256 bits, and you should enter a hexadecimal string that is 10, 26, or 58 characters long 
correspondingly. 
 

 
 
To save the current key set, click Save …. To load a previously saved key set, click Load …. 
 
The key set that you can enter or load using this dialog will be applied to packets captured in real-time, as well as to any CCF 
capture files that might have been saved previously. When captured packets are saved to a CCF capture file, those packets that 
were decrypted successfully will be saved in decrypted form, while those packets that could not be decrypted will be saved in the 
original, unmodified form. 
 



 

Reconstructing TCP Sessions 
 
This tool allows you to view the TCP conversation between two hosts.  To reconstruct a TCP session, you should first select a TCP 
packet on the Packets tab. If you want to reconstruct the entire session, it is recommended that you select the first packet in the 
session; otherwise, the reconstruction may start in the middle of the "conversation". After you locate and select the packet, right-
click on it and select Reconstruct TCP Session from the pop-up menu as shown below: 
 

 
 
Reconstructing sessions works best for text-based protocols, such as POP3, Telnet, or HTTP. Of course, you can also reconstruct a 
download of a large zipped file, but it can take CommView a long time to reconstruct several megabytes of data, and the obtained 
information would be useless in most of the cases. A sample HTTP session shown in ASCII and HTML modes is shown below: 
  

 
 

 
 



 
You can filter out the data that came from one of the directions by unchecking one of the check boxes on the bottom pane. 
Incoming and outgoing data are marked by different colors for your convenience. If you want to change one of the colors, click 
Settings =>Colors and pick a different color. You can enable or disable word wrapping using the Word Wrap item in the 
Settings menu.  
 
The Display type drop-down list allows you to view data in the ASCII (plain-text data), HEX (hexadecimal data), HTML (web 
pages), and EBCDIC (IBM mainframes' data encoding) formats. Please note that viewing data as HTML does not necessarily 
produce exactly the same result as the one you can see in the web browser (e.g. you will not be able to see inline graphics); 
however, it should give you a good idea of what the original page looked like. 
 
The Navigation buttons allow you to search the buffer for the next or previous TCP session between the two hosts. If you have 
multiple TCP sessions between the two hosts in the buffer and you'd like to see them all one by one, it is recommended to start the 
reconstruction from the first session, as the back button (<<) cannot navigate beyond the TCP session that was reconstructed first.  
 
The obtained data can be saved as binary data, text, or rich text file by clicking File =>Save As… . You can also search for a string 
in the session by clicking Edit => Find… . 
 



 
Statistics and Reports 
 
This window (View => Statistics) displays vital network statistics of your WLAN segment, such as packets per second rate, bytes 
per second rate, and IP protocols and sub-protocols distribution graphs. You can copy any of the graphs to the clipboard by double-
clicking on the graph. IP protocols and sub-protocols "pie" graphs can be rotated using the small buttons in the lower right corner 
for better visibility of the slices.  
 
The data displayed on each tab can be saved as a bitmap or semicolon-delimited text file using the context menu or drag-and-drop. 
The Report tab allows you to have CommView automatically generate customizable reports in HTML or semicolon-delimited text 
formats. 
 
Network statistics can be collected either by using all the data that passes through your network adapter or by using the rules that 
are currently set. If you want the statistics counters to process only the data (packets) that match the current rule set and ignore all 
other data, you should check the Apply current rules box. 
 
General   
Displays Packets per second and Bytes per second histograms, a bandwidth utilization chart (traffic per second divided by the NIC 
or modem link speed), as well as the overall packet and byte counters. 
 
IP Protocols 
Displays the distribution of the main IP protocols: TCP, UDP, and ICMP. Use the Chart by drop-down list to select one of the two 
available calculation methods: by number of packets or by number of bytes. If your WLAN uses WEP encryption, you must 
configure the WEP keys correctly to be able to decrypt network traffic; otherwise, this chart will be empty. 
 
IP Sub-protocols 
Displays the distribution of the main IP application-level sub-protocols: HTTP, FTP, POP3, SMTP, Telnet, NNTP, NetBIOS, HTTPS, 
and DNS. To add more protocols, click on the Customize button. This dialog allows you to define up to 8 custom protocols. You 
should enter a protocol name, select the IP protocol type (TCP/UDP), and port number. Use the Chart by drop-down list to select 
one of the two available calculation methods: by number of packets or by number of bytes.  If your WLAN uses WEP encryption, 
you must configure the WEP keys correctly to be able to decrypt network traffic; otherwise, this chart will be empty. 
 
Sizes 
Displays the packet size distribution chart. 
 
LAN Hosts (MAC) 
Lists active WLAN hosts by MAC address and displays data transfer statistics. You can assign aliases to MAC addresses. 
 
LAN Hosts (IP) 
Lists active WLAN hosts by IP address and displays data transfer statistics. Since IP packets captured by the program can be 
originated from an unlimited number of IP addresses (both internal to your WLAN and external), by default this tab doesn't display 
any statistics. To have the statistics displayed, you should first set the range of IP addresses to be monitored by clicking Add/Set 
Ranges. Normally, these ranges should belong to your WLAN, and configuring the program to monitor a certain range of IP 
addresses allows you to have the usage statistics. You can enter any number of ranges, but the total number of IP addresses being 
monitored cannot exceed 1,000. To delete a range, right-click on the list of ranges and select the appropriate menu command. You 
can assign aliases to IP addresses. If your WLAN uses WEP encryption, you must configure the WEP keys correctly to be able to 
decrypt network traffic; otherwise, this chart will be empty. 
 
 
Report 
This tab allows you to have CommView automatically generate customizable reports in HTML or semicolon-delimited text formats. 
 



 

Using Aliases 
 
Aliases are easy-to-remember human-readable names that CommView will substitute for a MAC or IP address when showing the 
packets on the Packets and Statistics tabs. This can make packets easier to recognize and analyze.  For example, 
00:00:19:2D:0D:35 becomes GATEWAY2, and ns1.earthlink.com becomes MyDNS. 
 
To add a MAC alias right-click on a packet and select Create Alias Using Source MAC or Using Destination MAC from the pop-
up menu. A window will pop up where the MAC address field is already filled out, and you will only need to type in an alias. 
Alternatively, you can click Settings => MAC Aliases … and fill out the MAC address and Alias fields manually. To delete an alias 
or clear the entire aliases list, right-click on the Aliases window and select Delete Record or Clear All. The same applies to 
creating IP aliases. When a new IP alias is created by right-clicking on a packet, the alias field is pre-filled with the corresponding 
hostname (if available) and can be then edited by the user.  
 

 
 



 
 

NIC Vendor Identifier 
 
The first 24 bits of a network card's MAC address uniquely identify the network card's vendor. This 24-bit number is called the OUI 
("Organizationally Unique Identifier").  The NIC Vendor Identifier is a tool that allows you to look up a vendor name by MAC 
address. To look up a vendor name, click Tools =>NIC Vendor Identifier, enter a MAC address, and click Find. The vendor's 
name will be displayed.   
 

 
 
The list of vendors is contained in the MACS.TXT file located in the CommView application folder. You can manually edit this list to 
add/modify information. 
 
 



 
Scheduler 
 
You can use this tool to create and edit scheduled capturing tasks. This is useful when you want CommView to start and/or stop 
capturing when you're not around, for example, at night or on weekends. To add a new task, click Tools => Scheduler, and then 
click on the Add button.  
 
 

 
 
Use the Start capturing frame to specify the date and time when CommView will start capturing. Use the Channel drop-down list 
to specify the WLAN channel that should be monitored. Use the Stop capturing frame to specify the date and time when 
CommView will stop capturing. You don't necessarily have to check both Start capturing and Stop capturing boxes. If you check 
only the first box, capturing would go on until you manually stop it. If you check only the second box, you'd have to start capturing 
manually, but then CommView would automatically stop capturing at the specified time.   
 
If CommView is already capturing packets at the time when the scheduled task is due and if the adapter you specified is different 
from the adapter currently being monitored, CommView will stop capturing, switch to the adapter you specified, and restart 
capturing.  
 
It is important to understand that the scheduled tasks can be performed only when CommView is running.  



 
Setting Options 
 
You can configure some of the program's options by selecting Settings in the menu. 
 
 
Fonts 
 
Use this menu to set the interface and packet text font. To change the packet text colors, use the Options menu (below). 
 
 
Options 
 
General 
 
Network 
 

Disable DNS resolving  – check this box if you don't want CommView to perform reverse DNS lookups of the IP 
addresses. If you check it, the Hostname column on the IP Statistics tab will be blank. 

 
Convert numeric port values to service names  – check this box if you want CommView to display service names 
rather than numbers. For example, if this box is checked, port 21 is shown as ftp, and port 23 as telnet. The program 
converts numeric values to service names using the SERVICES file installed by Windows. Depending on your Windows 
version, the SERVICES file is located in different folders: in Windows 95/98/Me you can find it in the \Windows folder, and 
in Windows NT/2000/XP, you can find it in the \Winnt\system32\drivers\etc folder. You can edit this file manually if you 
want to add more ports/service names. 
 
Convert MAC addresses to aliases – substitute MAC addresses for aliases on the Packets tab. Aliases can be assigned 
to MAC addresses using the Settings =>MAC Aliases menu command. 
 
Convert IP addresses to aliases – substitute IP addresses for aliases on the Packets and Statistics tabs. Aliases can 
be assigned to IP addresses using the Settings =>IP Aliases menu command. 
 
Convert IP addresses to hostnames in the "Packets" tab – check this box if you want CommView to show resolved 
hostnames rather than IP addresses in the Packets tab. If this box is checked, CommView will first attempt to find an alias 
for the given IP address. If no alias is found or the previous box (Convert IP addresses to aliases) is not checked, 
CommView will query the internal DNS cache for the hostname. If no hostname is found, the IP address will be displayed in 
numeric form.  
 
Forced WEP decryption – you should check this box if your wireless adapter erroneously reports that captured packets 
are not encrypted (the WEP flag in the 802.11 header is set to 0). This is the case with some adapters, for example, made 
by Belkin. To make CommView decrypt such packets, this option should be enabled. 
 
Capture Damaged Packets – Because of the distance, radio interference, and other physical phenomena, some packets 
received by your wireless adapter might be damaged, i.e. contain partly or fully invalid data. Check this box if you want the 
program to capture and display such packets. This option has both drawbacks and advantages. The advantage is that if you 
are located far away from WLAN stations and/or access points, a high percentage of packets might be broken, and enabling 
this option would allow you to see more data, even though the data might be partly damaged. However, the drawback is 
that you would see some packets with invalid data, e.g. you might see IP packets sent to non-existent IP addresses. Also, 
when this box is checked, the program will try decrypt those WEP-encrypted packets in which the Integrity Check Value is 
incorrect, but the headers appear to be valid.  
 

Memory Usage 
 
Display  
 

Maximum packets in buffer  – sets the maximum number of packets the program stores in the memory and can display 
in the packet list (2nd tab). For example, if you set this value to 3000, only the last 3000 packets will be stored in the 
memory and packet list. The higher this value is, the more computer resources the program consumes. 
 
Note that if you want to have access to a high number of packets, it is recommended that you use the auto-saving features 
(see Logging for more information): it allows you to dump all the packets to a log file on the hard drive. 
 
Maximum IP statistics lines  - sets the number of lines the program displays on the IP Statistics tab. When the number 
of connections exceeds the limit, the connections that have been idle for the longest period of time are removed from the 
list. 

 
Driver Buffer (Windows 2000/XP only) - sets the driver buffer size. This setting affects the program's performance: the more 
memory allocated for the driver buffer, the fewer packets the program drops. For low traffic LANs and dial-up connections, the 
buffer size is not critical. For high traffic WLANs, you may want to increase the buffer size if the program drops packets. To check 
the number of dropped packets, use the File => Performance Data menu command while capturing is on. 
 
IP Statistics 
 



Display Logic – allows you to select the IP Statistics layout that best suits your needs. Selecting an item from the drop-down list 
will display the description of the selected logic. In most cases, it is recommended to use the default Smart logic. 
 
Define Local IP Addresses – you should use this tool if you monitor WLAN traffic with many pass-through packets and a mixture 
of external and internal IP addresses. In such a situation CommView doesn't "know" which IP addresses should be treated as local 
and might reverse the IP addresses in the Source and Destination IP columns. This tool allows you to define the local network 
addresses and subnet masks to make sure the IP Statistics window works correctly. This will work only if you use the default Smart 
logic.  
 
 
Colors 
 
Packet color – sets the color for displaying packets on the Packets tab. 
 
Colorize Packet Headers – check this box if you want CommView to colorize packet contents. If this box is checked, the program 
displays the first four packet layers using different colors.  To change a color, select the type of header for which you want to 
change the color and click on the colored rectangular. 
 
Formula syntax highlighting – sets the colors for highlighting keywords in formulas in the Advanced Rules window. 
 
Selected byte sequence color – sets the color for displaying the byte sequence that was selected in the decoder tree. For 
example, when you select the "TCP" tree node, the corresponding part of the packet will be highlighted using this color.  
 
Decoding 
 
Always fully expand all nodes in the decoder window – check this box if you would like to have all nodes in the decoder 
windows automatically expanded when you select a new packet in the packet list. 
 
Decode up to the first level only in ASCII export – this option affects the decoding format used when you export a packet log 
or individual packet as ASCII file with decode. If this box is checked, only the top-level nodes will be saved. For example, if you 
save a TCP/IP packet when this option is disabled, all Type of service sub-nodes are saved. When this option is enabled, these sub-
nodes are not saved. Checking this box makes the output ASCII file less detailed and more compact. 
 
Ignore incorrect checksums when reconstructing TCP sessions – this option affects the way CommView treats malformed 
TCP/IP packets when reconstructing TCP sessions. By default, this option is on, and packets with incorrect checksums are not 
discarded in the process of reconstruction. If you turn off this option, packet with incorrect checksums will be discarded and not 
displayed in the TCP reconstruction window.  
 
Miscellaneous 
 
Hide from the taskbar on minimization  - check this box if you don't want to see the program's button on the Windows taskbar 
when you minimize the program. If this box is checked, use the program's system tray icon to restore it after minimization. 
 
Prompt for confirmation when exiting the application – check this box if you would like the program to ask you for a 
confirmation when you close it. 
 
Auto-scroll packet data window  - if this box is checked, the program scrolls the text of the packet data window automatically 
when you select a new packet from the packets list (but only if the text does not fit into the window). This is useful when you want 
to see the contents of a long packet without manually scrolling the window. 
 
Auto-scroll packet list to the last packet  - if this box is checked, the program automatically scrolls the packet list in the 
Packets tab down to the last received packet.  
 
Auto-sort new records in IP statistics  - if this box is checked, the program auto-sorts new records on the IP Statistics tab 
based on the user-defined sorting criterion  (e.g. ascending order of remote IP addresses).  
 
Smart CPU utilization control – if this box is checked, the program tries to decrease CPU utilization when capturing high-volume 
traffic by decreasing the quality and frequency of the screen updates.  
 
Run on Windows startup - if this box is checked, the program is launched automatically every time you start Windows. 
 
Run minimized - if this box is checked, the program is launched minimized and the main window is not displayed until you click 
on the tray icon or taskbar button. 
 



 
Find Packet 
 
This dialog (Search => Find Packet) allows you to find packets matching a specific text. Enter a search string, select the type of 
entered information  (String or Hex), and click Find Next. The program will search for packets that match the search criterion 
and display them on the Packets tab.  
 
You can enter text as a string, hexadecimal value, or IP address. A hex string should be used when you want to enter non-printable 
characters: just type hexadecimal character values separated by spaces, e.g. AD 0A 02 78 04. 
 
Check Match Case for case sensitive search. Check At offset to search for a string that begins at a certain offset. Note that the 
offset indicator is hexadecimal and zero-based (i.e. if you're looking for the first byte in the packet, the offset value is 0). 
 



 
Port Reference 
 
This window displays a table of port numbers and corresponding service names. This reference is obtained from the SERVICES file 
installed by Windows. Depending on your Windows version, the SERVICES file is located in different folders: In Windows 95/98/Me, 
you can find it in the \Windows folder, and in Windows NT/2000/XP, you can find it in the \Winnt\system32\drivers\etc 
folder. You can manually edit this file if you want to add more ports/service names. CommView reads this file on start up, so your 
changes to the file will be displayed only after you restart the program. 
 
 



 
Tips & Troubleshooting 
 
Frequently Asked Questions 
 
In this chapter you can find answers to some of the most frequently asked questions. The latest FAQ is always available at 
http://www.tamos.com/products/commwifi/faq.php 
 
Q. I'm on a wireless network, and I want to monitor my own inbound and outbound packets. Which product do I 
need: the standard, non-wireless CommView edition, or CommView for WiFi? 
A. You need the standard, non-wireless CommView edition. It will allow you to monitor your own traffic, but you will not be able to 
see the traffic of other WLAN stations. Unlike the standard CommView edition, CommView for WiFi allow you to monitor other 
wireless stations. 
 
Q. Do I need special hardware to use CommView for WiFi? 
A. You need a compatible wireless adapter. The list of compatible adapters can be found at 
http://www.tamos.com/products/commwifi/. You must install a special driver for your adapter. This driver comes with CommView 
for WiFi. Once this driver has been installed, your adapter will be put in passive, monitoring mode and will no longer be able to 
communicate with other wireless hosts or access points. To restore the standard functions of your adapter, you would need to roll 
back to the original adapter's driver, supplied by the vendor. If you would like to preserve your wireless connectivity while using this 
product, consider installing two wireless adapters, one of which would be used for monitoring, while the other would perform 
standard network functions. 
 
Q. My card is not on your list of supported hardware. What are my options? 
A. Firstly, this list includes ONLY those cards that we've tested ourselves in our test lab. There are many hardware vendors that use 
Prism 2/2.5/3 chipsets (we currently support primarily this chipset). Naturally, we cannot test all of these cards. If your PCMCIA or 
PCI card (sorry, no USB at this time) is based on the Prism 2/2.5/3 chipset and you are an advanced user who doesn't mind some 
testing, please go to http://www.tamos.com/products/commwifi/newcard.shtml, there is a good chance that your card will work 
with the existing driver. We will give a free license for CommView for WiFi in case of successful testing. If your card is NOT based 
on the Prism 2/2.5/3 chipset, you will have to wait until we implement the support for other chipsets, however we cannot give any 
guarantees or time estimates. Finally, if you don't want to wait, you may want to buy a compatible card, as they are not terribly 
expensive these days. We recommend Linksys WPC11 v.3 (about US$65). 
 
Q. I launched the program, selected the channel, started capturing, but no packets are displayed. Help!!! 
A. First, switch to the Packets tab. The IP Statistics tab might be empty if you did not enter correct WEP keys, and your WLAN 
uses WEP encryption. If the Packets tab is empty too, look at the program's status bar. If the packet counter is being incremented, 
then you have active rules that prevent the program from displaying packets. Click Rules => Reset All, and then press three 
toolbar buttons: Capture Data Packets, Capture Management Packets, and Capture Control Packets. If the packet counter 
on the status bar is not being incremented, then there are probably no active wireless stations or access points available/detected. 
If you are absolutely certain that there are wireless stations or access points, report this problem to us. 
 
 
Q. Can CommView for WiFi read CCF log files generated by the standard, non-wireless CommView edition? How 
about vice versa? 
A. Yes, CommView for WiFi can read CCF log files generated by the standard, non-wireless CommView edition. The standard, non-
wireless CommView edition can read CCF log files generated by CommView for WiFi, but (a) you need CommView 4.0 Build 321 or 
higher, and (b) you will not be able to see wireless-specific columns, such as signal strength or WEP key number. 
 
Q. Does CommView for WiFi run on multi-processor computers? 
A. Yes, it does.  
 
Q. My firewall software warns me that CommView for WiFi is "attempting to access the Internet." I am aware that 
some sites are able to track users by collecting the information sent by their programs via Internet. Why does 
CommView "attempt to access the Internet"? 
A. What alerts your firewall is the attempt to resolve IP addresses to hostnames. Since CommView has to contact your DNS servers 
to make a DNS query, it inevitably triggers the alarm. You can disable this feature (Settings => Options => Disable DNS resolving), 
but in this case, the IP Statistics tab will not be able to show you the hostnames. DNS queries are the only type of connection 
CommView can potentially make. There are no other hidden activities. We don't sell spyware.  
 
Q. Under Windows 2000/XP I'm often logged on as a user without administrative privileges. Do I have to log off and 
then re-logon as the administrator to be able to run CommView? 
A. No, you can open CommView folder, right-click on the CV.exe file while holding down the Shift key, and select "Run As" from the 
pop-up menu. Enter the administrative login and password in the window that pops up and click OK to run the program.  
 
  
  
 

http://www.tamos.com/products/commwifi/faq.php
http://www.tamos.com/products/commwifi/
http://www.tamos.com/products/commwifi/newcard.shtml


 

Running CommView for WiFi in Invisible Mode 
 
There are two ways to run CommView as a hidden process: 
 

1. Launch CommView with the "hidden" switch, i.e.:  
 

 CV.EXE hidden 
 

2. If CommView is already running, you can hide/unhide it by using the "hot key". To hide the application, press 
ALT+SHIFT+h. To unhide the application, press ALT+SHIFT+u. 

 
Remember that you cannot completely hide any Windows application. When running in invisible mode, CommView is not listed in 
the task list (the one that is invoked by pressing ALT+CTRL+DEL) under Windows 95/98/ME, but one can still see it by using any 
utility that lists running processes. Under Windows NT/2000/XP this utility is a part of the Task Manager.  
  
 



 

Command Line Parameters 
 
You can use command line parameters to perform the following operations when the program is being launched: 
 

• Load and activate a rule set from a file. Use the "/ruleset" switch followed by the file name and full path, e.g.: 
 

CV.EXE /ruleset "C:\Program Files\CommView\Rules\POP3Rules.rls" 
 
If a file name or its path contains spaces, it must be enclosed in quotation marks (" "). 

 
• Load and activate a WEP key set from a file. Use the "/keyset" switch followed by the file name and full path, e.g.: 

 
CV.EXE /keyset "C:\Program Files\CommView\WLAN3Keys.wep" 
 
If a file name or its path contains spaces, it must be enclosed in quotation marks (" "). 

 
You can use both of these parameters at the same time. 
 



 

Exchanging Data with Your Application 
 
Starting from version 3.0, CommView provides a simple TCP/IP interface that allows you to process packets captured by CommView 
using your own application in real time. 
 
How It Works 
You should launch CommView with a special command-line switch, telling the program to "mirror" captured packets to an IP 
address and TCP port of your choice.  
 
Examples: 
CV.EXE mirror:127.0.0.1:5555  // mirrors packets to the loopback address, TCP port 5555 
CV.EXE mirror:192.169.0.2:10200  // mirrors packets to 192.169.0.2, TCP port 10200 
 
When CommView is launched with a switch like this, it tries to establish a TCP session by connecting to the specified IP address and 
port number. It means that you should already have your application running and listening on the specified port. If CommView fails 
to establish a connection, it will keep on trying to connect every 15 seconds. The same happens if the connection is broken: 
CommView will try to re-establish it every 15 seconds. If the connection is successfully established, CommView sends the packets it 
captures to the specified IP address as they arrive, in real time. 
 
Data Format 
Since packets are being sent as a stream, and you must be able to identify individual packets, CommView uses simple headers that 
allow you to "chop" the stream into individual packets. Each packet is preceded by a 3-byte header. The first two bytes are the 
packet length, excluding this header. These bytes are in the standard little-endian byte order, i.e. 0x0200 equals 2, and 0x0002 
equals 512. The third byte is the packet direction: 
 
0x00 - pass-through 
0x01 - inbound 
0x02 – outbound 
 
Examples: 
 
0xE80000 - a pass-through packet, 232 bytes long 
0xB10102 - an outbound packet, 433 bytes long 
 
Based on this description, you can easily create a packet parser that would extract packets from the stream. 
 
Sample Projects 
Two simple demo applications that listen for inbound connections, extract packets from the stream, and display raw data are 
available. 
 

• http://www.tamos.com/products/commview/samp_mirr_c.zip. This is a Visual Studio project with C++ source code. 
 

• http://www.tamos.com/products/commview/samp_mirr_d.zip. This is a Delphi project with Pascal source code. If you 
want to compile the project, you'll need the popular ICS components suite by François Piette available at 
http://overbyte.delphicenter.com/frame_index.html 

 
Bandwidth 
When mirroring data to a remote computer, make sure that the link between CommView and the computer to which the data is 
being mirrored is fast enough to transfer all the data being captured. If CommView captures 500 Kbytes/sec, and your link can 
handle only 50 Kbytes/sec, you'd inevitably have "traffic jams", which might result in various problems (e.g., Winsock may just stop 
sending data under some Windows versions).  
 
 

http://www.tamos.com/products/commview/samp_mirr_c.zip
http://www.tamos.com/products/commview/samp_mirr_d.zip
http://overbyte.delphicenter.com/frame_index.html


 
Custom Decoding 
 
Starting from version 4.0, CommView allows you to use your own decoder. If you implement one, the output of your decoder will 
be displayed in the additional column in the Packets tab. Your decoder must be a 32-bit DLL file named "Custom.dll" that exports 
the only procedure named "Decode". The prototype of this procedure is shown below in C and Pascal: 
 
extern "C" { 
  void __stdcall Decode(unsigned char *PacketData, int PacketLen, char *Buffer, int BufferLen); 
} 
 
procedure Decode (PacketData: PChar; PacketLen: integer; Buffer: PChar; BufferLen: integer); stdcall;  
 
The DLL must be located in the CommView application folder. When you launch CommView, it looks for "Custom.dll" in the 
application folder and loads it into memory. If the "Decode" entry point is found, CommView adds a new column named "Custom" 
to the packet list.  
 

When a new packet is captured and is about to be displayed, CommView calls the "Decode" procedure and passes the packet 
contents to the DLL. The "Decode" procedure must process the packet data and copy the result to the supplied buffer. The first 
argument is the pointer to the packet data, the second argument is the data length, the third argument is the pointer to the buffer 
where the results of your decoding must be copied to, and the forth argument is the buffer size (currently always 1024 bytes). The 
buffer is allocated and freed by CommView, so don't attempt to reallocate or free it. The result that you copied to the buffer will be 
displayed as a string in the "Custom" column.  

 

Your procedure must be fast enough to handle thousands of packets per second; otherwise it may slow down the application. Don't 
forget to use the STDCALL calling convention.  

 

Sample Projects 
 
Two demo DLLs are available. They demonstrate a very simple operation: The output of the "Decode" function is the hex code of 
the packet's last byte. Your own decoder can be as complex as you wish. 
 

• http://www.tamos.com/products/commview/cust_decoder_c.zip. This is a Visual Studio project with C++ source code. 
 

• http://www.tamos.com/products/commview/cust_decoder_d.zip. This is a Delphi project with Pascal source code. 
 

http://www.tamos.com/products/commview/cust_decoder_c.zip
http://www.tamos.com/products/commview/cust_decoder_d.zip


 
Information 
 
How to Purchase CommView for WiFi 
 
This program is a 30-day evaluation version. 
 
A fully functional, unrestricted version of the program can be purchased for US$399.  
 
Those customers who previously purchased the standard, non-wireless CommView edition are eligible for a considerable discount; 
please visit our web site for the details.  
 
One licensed copy of CommView may be used by a single person who uses the software personally on one or more computers, or it 
may be installed on a single workstation used non-simultaneously by more than one person, but not both. Check our web site for 
pricing on multiuser licenses if you need to purchase this product for more than one user.  
 
 
As a registered user, you will receive: 
 

• Fully functional, unrestricted copy of the software 
• Free updates that will be released within 1 year from the date of purchase 
• Information on updates and new products 
• Free technical support 

 
We accept credit card orders, orders by phone and fax, checks, purchase orders, and wire transfers. Prices, terms, and conditions 
are subject to change without notice: please check our web site for the latest product offerings and prices. 
 
http://www.tamos.com/order/ 
 

http://www.tamos.com/order/


 
Contacting Us 
 
Web 
 
http://www.tamos.com  
 
 

E-mail 
 
 
sales@tamos.com (Sales-related questions)  
support@tamos.com (All other questions)  
 
 
Mail and Fax 
 
Mailing address: 
 
PO Box 1385 
Christchurch 8015 
New Zealand  
 
Fax: +64 3 359 0392 (New Zealand) 
Fax: +1 503 213-7764 (USA) 
 
 
 

http://www.tamos.com/
mailto:sales@tamos.com
mailto:support@tamos.com


 
Other Products by TamoSoft 
 
 
CommTraffic 
 
CommTraffic is a network utility for collecting, processing, and displaying traffic and network utilization statistics for network 
connections, including LAN and dial-up. It shows traffic and network utilization statistics for each computer in the segment. The 
software provides a very attractive and customizable interface, with an optional tray icon menu that displays general network 
statistics. You can also generate reports that reflect the network traffic volume and Internet connection expenses (if any). 
CommTraffic supports virtually any rate plan your ISP might use, such as the one based on connection time, traffic volume, time of 
the day, and other measures. You can set alarms that will inform you when certain criteria (e.g. amount of traffic, expenses) are 
reached. A configuration wizard will guide you through the setup and automatically detect your network or connection settings. 
 
More information 
 
SmartWhois 
 
SmartWhois is a handy utility for obtaining information about any IP address, hostname, or domain in the world. Unlike standard 
whois utilities, it automatically delivers information associated with an IP address or domain no matter where it is registered 
geographically. In just a few seconds, you get all you want to know about a user: domain, network name, country, state or 
province, and city. Even if the IP address cannot be resolved to a hostname, SmartWhois won't fail! 
 
More information 
 
Essential NetTools 
 
Essential NetTools is a set of network tools useful in diagnosing networks and monitoring your computer's network connections. It's 
a Swiss Army knife for everyone interested in a set of powerful network tools for everyday use. The program includes a NetStat 
utility that shows your computer's network connections and open ports and maps them to the owning application. It also features a 
fast NetBIOS scanner, a NetBIOS Auditing Tool for checking LAN security, and a monitor of external connections to your computer's 
shared resources, as well as a process monitor that displays information about all the programs and services running on your 
computer. Other useful tools are included, such as Ping, TraceRoute, and NSLookup. Additional features include report generation 
in HTML, text, and comma delimited formats and a customizable interface. The program is an easy-to-use and powerful 
replacement for such Windows utilities as nbtstat, netstat, and NetWatcher. It incorporates many advanced features that standard 
Windows tools can't offer. 
 
More information 
 
 
DigiSecret 
 
DigiSecret is an easy-to-use, secure, and powerful application for file encryption and sharing. It utilizes strong and time-proven 
encryption algorithms for creating encrypted archives, self-extracting EXE files, and sharing files with your associates and friends. 
DigiSecret also includes powerful and intelligent file compression; you no longer need .zip files when you can have encrypted and 
compressed DigiSecret files. The program is integrated with the Windows shell, and you can perform operations on files by right-
clicking on them. It also fully supports drag-and-drop operations. 
 
More information 
 

http://www.tamos.com/products/commtraffic/
http://www.tamos.com/products/smartwhois/
http://www.tamos.com/products/nettools/
http://www.tamos.com/products/digisecret/
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