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Introduction 
 

About SmartWhois 
 
SmartWhois is a useful network information utility that allows you to find out all available information about an IP address, host 
name, or domain, including country, state or province, city, name of the network provider, administrator, technical support, and 
abuse contact information. 
 
Unlike standard Whois utilities, SmartWhois can find the information about a computer located in any part of the world, intelligently 
querying the right database and delivering all the related records within a few seconds. The program can retrieve information from 
more than 60 servers all over the world. 
 
SmartWhois can save obtained information to an archive file. Users can load this archive the next time the program is launched and 
add more information to it. This feature allows you to build and maintain your own database of IP addresses and host names. The 
obtained records may also be saved in one of the several formats: HTML, text, XML, and XLS. Another useful feature in SmartWhois 
is the ability to load a list of IP addresses or domain names as a text file and process it. 
 
SmartWhois is capable of caching query results, which reduces the time needed to query an address; if the information is in the 
cache file it is immediately displayed and no connections to the whois servers are required. 



 

 What's New 
 

Version 5.0 

• Internationalized domain names (IDN) are now supported. 
• Unicode is now supported throughout the application. Information on domain owners in any language is now displayed 

correctly. 
• IPv6 addresses are now supported. 
• The application engine has been rewritten. The new engine supports multithreading, which dramatically speeds up 

processing of batch queries. 
• Added support for the following domain zones: FM, AC, AR, CA, BE, CL, ASIA, TR, SK, LT, LV, HK. Updated data parser 

for many other domain zones. 
• Displays geographic coordinates for domains or IP addresses that have LOC records. 
• Automatically detects query types based on the user input. 
• New query type: As IP and as domain simultaneously. 
• You can perform multiple queries in the query box with a single click, simply enter multiple IP addresses or domains 

separated by commas. 
• Multiple proxy servers are now supported. A random proxy server may be used every time the application connects to a 

whois server. 
• Spam/abuse templates have been improved. Customization and selection of different templates for IP address or Domain 

abuse reports is now supported. 
• The application can query multiple IP addresses assigned to a host. 
• Many other improvements. 
 

Version 4.3 

• Displays Google Page Rank and Alexa Traffic Rank for domain queries. 
• Can perform queries for the text on the clipboard and in other application windows without the need to perform 

copy/paste. 
• Hot keys that allow you to quickly invoke a number of SmartWhois windows or perform queries for the text on the 

clipboard and in other application windows. 
• Integration into Windows Explorer for quick batch processing of files. 
• Parsing modules and IP allocation map have been updated. 
• Added support for the following domains: AM, BG, CD, GD, GI, GY, HN, IN, IR, IS, KI, KZ, LA, LY, RE, SC, TC, TF, VC, VG, 

WF, YT. 
• A few other improvements. 

 
 



 

Using SmartWhois 
 

Quick Start 
 
If you don't like reading long manuals and you are already familiar with the Internet, this is probably the only chapter you need to 
read to get started.  
 
Step 1.  
Launch the program. 
 
Step 2.  
Type in or paste an IP address, hostname, or domain name. An example of an IP address query is shown below: 
 
 

 
  
A hostname query:  
 

 
 
A domain name query: 
 

 
 
 
Step 3.  
Click the Query button or press the Enter key. The program will try to automatically detect whether you entered an IP address, 
hostname, or domain and make the respective query. You can also explicitly tell the program which query type should be 
performed: 
 
Make an IP address or hostname query by clicking Query =>As IP address / Hostname or press the Enter key while holding 
down the Shift and Ctrl keys (Shift+Ctrl+Enter).  
 
Or 
 
Make a domain query by clicking Query => As Domain or press the Enter key while holding down the Ctrl key (Ctrl+Enter). 
 
Or 
 
 
Query the input text as both IP address/hostname and domain by clicking As IP / Hostname and Domain or press the Enter key 
while holding down the Shift and Alt  keys (Shift+Alt+Enter). 
 
 
 

 
 
The default query type and respective hotkey combinations can be customized in (Settings => Options => Queries). 



 

Main Window and Menu 
 
The program main window consists of the input area where you can enter your query, the menu and toolbar for performing 
standard operations, and the output window where query results are displayed. The output window consists of the Results tree (the 
left panel) that lists all queried IP addresses and domains, and the text area (the right panel), where the current query information 
is displayed.  
 

 

 
 
To obtain information about an IP address, hostname, or domain, just enter it in the input box and hit the Enter key (Ctrl+ Enter in 
case of domain queries or Shift + Ctrl + Enter in case of IP / Host queries), or click on the Query button. Alternatively you can 
choose a recent query from the drop-down list. If you would like to learn more about the difference between IP addresses, 
hostnames, and domains, please see the Types of Queries chapter. 
 
SmartWhois displays information obtained from the whois servers as a set of items represented by icons. A query result does not 
necessarily contain all of the items because the amount of data returned by whois servers depends on the specific IP address. Click 
here to see the meaning of the right panel icons.  
 
The left panel displays all the IP addresses and domain names you have queried during the session represented by icons. Every IP 
address, hostname, or domain in the tree is represented by a node that includes several branches. The parent node is the IP 
address, hostname, or domain that you entered. The child branches are the net blocks in which this IP address was found. You can 
browse through the branches by clicking on them. When a new query is sent all the old threads are collapsed and a new thread is 
created. Click here to see the meaning of the results tree icons. 



 
 

Main Menu  

File 

Clear - clears the output window, both the Results tree and the text area. 

Open – opens a SmartWhois archive or batch file. If a SmartWhois archive is opened its contents are displayed. If some results are 
already present in the Results tree and text area, they will be merged with the archived data. If a batch file is opened, all IP 
addresses or domain names contained in it are processed.  

Save - All Results - saves all the results from the tree into a SmartWhois archive, XML, XLS, or text file. 

Save - Selected Results - saves selected results from the tree into a SmartWhois archive, XML, XLS, or text file. 

Save - Current Result - saves the current result from the text area into a SmartWhois archive, HTML, XML, XLS, or text file. 

Print - prints the current text area. 

Exit - closes the program. 

Query 

As IP address / Hostname – performs an IP address / Hostname query. 

As Domain – performs a domain query. 

Clipboard – performs queries for the text on the clipboard. 

Last Active Window – performs queries for the text in the last active window of a 3rd party application. 

Stop – terminates queries in progress. This item is grayed when no query is being performed.  

Refresh – updates selected queries in the Results tree by contacting the whois server again. 

Edit 

Copy - copies selected text from the text area to the clipboard.  

Paste - pastes the clipboard contents into the input area. 

Delete – deletes selected text in input area. If the Results tree is active, the selected queries in the tree will be deleted. 

Select All - selects all text in the text area. If the Results tree is active, all queries in the tree will be selected. 

View 

Toolbar - shows or hides the toolbar. 

Panel Headers – shows or hides the headers of the results and information details panels. 

Results Panel – shows or hides the left panel. 

Status Bar - shows or hides the status bar. 

Source - opens a window that shows raw information as it was received from the whois server. 

Whois Console – opens a window for making a custom query. You can specify the whois server you want to query and make a 
specific type of query. 

My Notes – opens a window where you can enter your notes about IP addresses, hostnames, or domain names.  

Country codes  - opens a window with the list of countries and two letter codes assigned to them.  

Settings 

Language – allows you to select the SmartWhois interface language. 

Ping hosts – check this item if you want SmartWhois to ping hosts. See the Configuring SmartWhois chapter for more information. 

Resolve IP Address to Hostname – check this item if you want SmartWhois to perform a reverse DNS lookup. See the 
Configuring SmartWhois chapter for more information. 

Options – opens the configuration dialog 



 

Help 

Contents – opens the help file. 

Search For Help On – opens the SmartWhois help index. 

Getting Started – displays the SmartWhois usage hints in the text area. 

Online Tutorial – opens the Web site with SmartWhois tutorial. 

Check for an Update on the Web – opens the update downloading dialog window. Please follow the instructions on the screen 
to download and install the latest upgrade for SmartWhois from the TamoSoft web site. 

About – shows the About window. 

 

Right-clicking on the Results tree pops up the following menu: 

Save - saves the information about the selected queries into a SmartWhois archive, XML, XLS, text, or HTML file. 

Refresh - refreshes the results of the selected queries. 

Delete - deletes selected queries. 

Select All – selects all results in the tree. 

View Source - opens a window and shows raw information as it was received from the whois server. View Source window has a 
context menu that allows you to copy the output to the clipboard, select and save the output, change the font for the window, or 
toggle word wrap.  

Whois Console – opens whois console; the selected IP address or domain is filled into the query field.  

My Notes – opens a window where you can put your notes about IP addresses, hostnames or domain names. 

Show IPv6 ranges as CIDR – if this option is enabled, IPv6 ranges in the Results tree will be shown in the CIDR format. This 
saves some space in the left panel. 

 

Right-clicking on the right panel pops up a context menu with the following commands: 

Copy - copies selected text to the clipboard. 

Copy URL – copies the URL under the mouse pointer to the clipboard. 

Select All - selects all text in the text area. 

View Source - opens a window and shows raw information as it was received from a whois server. View Source window has a 
context menu that allows you to copy the output to the clipboard, select and save the output, change the font for the window, or 
toggle word wrap.  

Search for - allows you to search for the selected text using one of the major Web search engines or Usenet. You can modify the 
list of the search engines by clicking Search for => Configure.  

Abuse/Spam Reporting – use this command to pass the information about the owner of an IP address or domain to your e-mail 
application. When you use this command, SmartWhois will create a new message in your e-mail application and put some basic 
information into the body message. Be sure to customize this message before sending it, i.e. include all the details about the 
network attack or spam message headers.  



 

Icons and Their Meanings  
 
 
Left Panel 
 
 

 IP address, hostname or net block; the query is in the  queue and will be processed as soon as possible. 
 

 IP address, hostname or net block; the query is currently in progress. 
 

 IP address, hostname or net block; the query is partially complete. While the basic information has been received from a 
whois server and can be viewed, additional data (DNS server information, ping information, etc.) is still being received from a 
whois server. 

 

 IP address, hostname or net block; an error occurred during processing a query. 
 

 IP address, hostname, or net block; the information is obtained online. 
 

 IP address, hostname, or net block; the information is obtained from the local cache or is loaded from a SmartWhois archive. 
 

 Domain; the query is in a queue and will be processed as soon as possible. 
 

 Domain; the query is currently in progress. 
 

 Domain; the query is partially complete. While the basic information has been received from a whois server and can be 
viewed, additional data (DNS server information, Google/Alexa ranks, etc.) is still being received from a whois server. 

 
 

 Domain; an error occurred during processing a query; 
 

 Domain; the information is obtained online. 
 

 Domain; the information is obtained from the local cache or is loaded from a SmartWhois archive. 
 

 Domain not found; the information is obtained online. 
 

Domain not found; the information is obtained from the local cache or is loaded from a SmartWhois archive. 
 
 
Right Panel 
 

 IP address or domain that was queried, as well as optional ping and hostname information. 
 

 Default (the narrowest) net block assigned to the IP address. For domain queries, this icon shows the domain's IP address, if 
any. 
 

 IP address / domain owner. It can be a company name for corporate networks or an Internet Service Provider (ISP) name 
for dial-up connections. 
 

 Administrative contact and all the related information: address, telephone and fax numbers, e-mail, etc. 
 

 Technical contact and all the related information: address, telephone and fax numbers, e-mail, etc. 



 

 Billing contact and all the related information: address, telephone and fax numbers, e-mail, etc. 
 

 Abuse contact and all related information: address, telephone and fax numbers, e-mail, etc. 
 

 Name servers assigned to the IP address / domain. 
 

 Google Page Rank and Alexa Traffic Rank information. Note that this information is available for domain queries only. Be 
sure to enable the corresponding options (Check for Google Page Rank and/or Check for Alexa Traffic Rank checkboxes) in 
the Options dialog (Settings => Options) for this information to be displayed. 
 

 Registered internal Internet name of the network, registration date (sometimes the registration information last modification 
date) and the source of the information. 
  



 

Types of Queries 
 
 
Information for Beginners 
 
It's important to understand the difference between IP addresses, hostnames, and domains. An IP address is a unique number 
that identifies a computer on the Internet, for example 205.181.112.65. You may want to obtain information about an IP address to 
find out who is the real sender of an e-mail message, or who is attacking your computer.   
 
A hostname is just an easy-to-remember name corresponding to an IP address. For example, www.tamos.com is the name for the 
IP address 209.68.11.237. A whois query for www.tamos.com and 209.68.11.237  returns exactly the same information.   
 
Please note that multiple IP addresses may be assigned to a hostname: for instance, yahoo.com has 2 different IP addresses 
(206.190.60.37 and 68.180.206.184 respectively). If you would like SmartWhois to query all IP Addresses assigned to a hostname, 
enable the Query all IP addresses assigned to hostname option (Settings => Options => Network => Advanced). 
 
Domains are different from hostnames and IP addresses. A domain is a network name registered to someone. Domain queries 
provide information about the owner of a domain name. For example, if you want to purchase the cats.com domain name to make 
a web site about cats, you may want to contact the current owner of this domain to discuss the deal. To obtain the information 
about the domain name owner you need make a domain query. 
 
SmartWhois is capable of performing both IP address/hostname and domain name queries. 
 
 
IP Address / Hostname Queries  
 
To obtain information about an IP address or a hostname, just enter it in the input box and hit the Enter key (in which case the 
application will attempt to guess whether you entered an IP address / hostname or domain), or click on the Query arrow button 
and select As IP address / Hostname. You can choose a recently queried IP address or host name from the drop-down list. The 
examples of IP addresses are 204.71.203.160, 216.115.104.67, 195.14.130.100 (IPv4 addresses) or 
2001:a00e:0000:0260:97ff:fe40::efab (IPv6 address). The examples of hostnames are quote.yahoo.com, adsl-235-235-
239.mco.bellsouth.net, or www.ebay.com. SmartWhois also supports IP addresses with wildcards, such as 193.1.*.* or 193.1.217.* 
. In this case the program will scan the specified range of addresses and display all entries found. 
 
 
Domain Queries 
 
If you want to query a domain registration database, enter a domain name and hit the Enter key (in which case the application will 
attempt to guess whether you entered an IP address / hostname or domain), or click on the Query arrow button and select As 
Domain. The examples of valid domain names are yahoo.com, volvo.se, or ford.co.uk. Don't use the "www" prefix in your domain 
queries; for example www.micorsoft.com is not a valid domain query (albeit a valid hostname query). 
 
 
Dual Queries 
 
Sometimes you may want to find out the information on the IP address and domain name at the same time. For example, you can 
enter wikipedia.org and query this data as an IP address / hostname (to find out where the server is located) and as a domain (to 
find out who owns this domain). In this case, click on the Query arrow button and select As IP / Hostname and Domain. 
 
 
Custom Queries 
 
If you need to query a non-default whois server or make a special query click View => Whois Console from the menu or click 
Query button and select Custom Query. 
 
 
Clipboard Queries 
 
If you would like to query information located on the clipboard, click Query => Clipboard and select the preferred query type. 
This option is available in both main window and tray icon menus. The following options are available: 
 
As IP address – select this option if you want to query the clipboard text as an IP address. 
As Domain – select this option if you want to query the clipboard text as a domain. 
 
When selecting any of the query types above, SmartWhois will perform the respective query for the first word found in the 
clipboard text. 
 
As Text Containing IP Addresses – if you select this option, all IP addresses in the clipboard text will be processed regardless of 
their arrangement. 
As List of IP Addresses / Hostnames – clipboard text will be processed as a list of IP addresses or hostnames. The first word 
on every line will be processed as IP address or hostname. This option is suitable for processing log files. 
As List of Domains – this option is similar to the one above, except that the clipboard text will be processed as a list of domains. 
 



In case the program window is inactive, you will still be able to perform queries by using hotkeys that can be assigned to any of the 
above-mentioned commands. Please see the Configuring SmartWhois chapter for more information on using hotkeys. Please note 
that hotkeys are disabled by default. 
 
 
Window Queries 
 
To query information located in the active window, right-click the SmartWhois icon located in the tray and select Query => 
Current Window. Next, select the desired query type.  
 
The following options are available: 
 
As IP address – select this option if you want to query the contents of the active window as an IP address. 
As Domain – select this option if you want to query the contents of the active window as a domain. 
 
When selecting any of the query types above, SmartWhois will perform the respective query for the first word found in the window. 
 
As Text Containing IP Addresses – if you select this option, all IP addresses in the window will be processed regardless of their 
arrangement. 
As List of IP Addresses / Hostnames – window contents will be processed as a list of IP addresses or hostnames. The first 
word on every line will be processed as IP address or hostname. This option is suitable for processing log files. 
As List of Domains – this option is similar to the one above, except that the text will be processed as a list of domains. 
 
If you need to process just a part of the text in the window, highlight it before performing the query. In case the program window 
is inactive, you will still be able to perform queries by using hotkeys that can be assigned to any of the above-mentioned 
commands. Note: this option is available for windows that support standard system text extraction methods only. Please see the 
Configuring SmartWhois chapter for more information on using hotkeys. Please note that hotkeys are disabled by default. 
 



 

World Coverage 
 
 
SmartWhois uses five main servers for IP queries and more than 60 regional whois servers to obtain domain registration records. 
Note that there are many countries that don't have whois databases, and information for such national domains cannot be 
obtained. SmartWhois currently covers the following domain zones: 
 
AC, AE, AERO, AF, AM, AR, ASIA, AT, AU, BE, BG, BIZ, BR, BT, BZ, CA, CAT, CC, CD, CH, CL, CN, COM, COOP, CX, CZ, DE, DK, 
EDU, ES, EU, FI, FM, FR, GD, GI, GOV, GY, HK, HN, HU, IE, IL, IN, INFO, INT, IR, IS, IT, JOBS, JP, KI, KR, KY, KZ, LA, LI, LT, LU, 
LV, LY, ME, MOBI, MS, MUSEUM, MX, MY, NAME, NET, NL, NL, NO, NU, NZ, ORG, PL, PRO, PT, PW, RE, RO, RU, SC, SE, SG, SI, SK, 
SU, TC, TF, TH, TK, TM, TR, TRAVEL, TV, TW, UA, UK, US, VC, VG, WF, WS, YT. 
 
SmartWhois also fully supports Internationalized Domain Names (IDN) that use non-ASCII characters, for example שלום.com, 
погода.com, bücher.ch. 
 



  

Batch Processing 
 
SmartWhois can process lists of IP addresses, hostnames, or domain names saved as plain text (ASCII) or Unicode files. The valid 
format for such batch files is simple: each line must begin with an IP address, hostname, or domain. If you want to process domain 
names, they must be located in a separate file from IP addresses and hostnames. If an IP address, hostname, or domain name is 
followed by other characters/words placed on the same line, there must be at least one space separating them from the first word 
on a line. Below is an example of a batch file, which is a standard web server log: 
 
133.169.11.1 - - [10/Apr/2000:08:09:32 -0400] "GET /en.htm HTTP/1.0" 200 5413 "-" "Mozilla/4.0 (compatible; MSIE 4.01; 
Windows 98)" 
24.19.132.144 - - [10/Apr/2000:08:09:33 -0400] "GET /images/l2.gif HTTP/1.1" 200 848 "http://www.tamos.com/" "Mozilla/4.0 
(compatible; MSIE 5.01; Windows NT 5.0)" 
194.45.56.32 - - [10/Apr/2000:08:09:34 -0400] "GET /download.htm HTTP/1.0" 200 10921 "http://www.tamos.com/" "Mozilla/4.61 
[en] (WinNT; I)" 
 
Another sample batch file: 
 
203.160.224.66  
199.107.4.10  
ns0.apecs.co.jp 
161.196.244.104 
24.94.163.6  
pool0142.cvx25-bradley.dialup.earthlink.net 
210.145.100.82 
 
An example of a domain name batch file: 
 
toyota.com 
starpower.net 
force9.co.uk 
volvo.se 
 
Additionally, the Text Containing IP Addresses batch query type is supported. If this option is selected, SmartWhois searches 
for IP addresses in text files and makes respective IP queries. 
 
You can automate batch processing using command line options.  
 



 

Command Line Options 
 
SmartWhois supports command line parameters specifying IP address/hostname/domain, as well as files to be opened/saved. There 
are two query types supported: Simple queries and Batch queries. 
 
Simple Queries 
 
To launch SmartWhois and make it query an IP address/hostname or domain, you don't need to use any parameters except the IP 
address/hostname/domain itself: 
 
SW.EXE 207.46.197.113 
SW.EXE www.yahoo.com 
 
By default, SmartWhois automatically detects your input and queries 207.46.197.113 as IP address and yahoo.com as domain. 
Specific queries can be made using following parameters: 
 

-d specifies that the program should make a domain query. 
 

-i specifies that the program should make an IP / hostname query. 
 

 
Examples: 
 
 
SW.EXE yahoo.com -d 
SW.EXE www.etrade.com –i 
 
Additionally you can run a dual query (IP / Hostname and Domain) by specifying the "2" symbol as a query type parameter: 
 
SW.EXE www.etrade.com –2 
 
Optional simple query parameters: 
 

-os specifies that the query results are sent to the active console application, such as the command prompt. If you use 
this parameter when executing a query from the command prompt, the query results will be printed in the command 
prompt window. This option works in Windows XP/2003 or higher. 

-h specifies that the query is processed without opening the program's main window. Please note that the SmartWhois 
tray icon will always be displayed when this parameter is used. The icon will disappear when the program's main 
window is opened by right-clicking on the icon and selecting Show from the menu, or by double-clicking on the 
icon. 

-c specifies that the program must close after the query is processed. This parameter should be used only in 
conjunction with the "-os" parameter and must be preceded by it. 

 
Examples: 
 
SW.EXE yahoo.com -os -h -c 
 
SW.EXE yahoo.com -d -os -h -c 
 
 
Batch Queries 
 
You can use command line parameters for performing complex batch tasks, such as loading a list of IP addresses, processing the 
list, saving the obtained results into a text file, and exiting. The following parameters exist: 
 

-b specifies that the program should work in batch mode. This parameter is mandatory in the batch mode and should 
be the first one. 

-st specifies that the next argument is a text file containing IP addresses. This parameter is mandatory in the batch 
mode when the "As text containing IP addresses" query option is selected. 

-si Specifies that the next argument is a source file containing a list of IP addresses. This parameter is mandatory in the 
batch mode when querying a list of IP addresses. 

-sd specifies that the next argument is a source file containing a list of domains. This parameter is mandatory in the 
batch mode when querying a list of domains. 

 
Examples: 
 
SW.EXE -b -sd C:\LOGS\domains.txt  
The program reads domains from list.txt and processes the list without saving results. 
 



 
Optional parameters: 
 

-ot specifies that the next argument is an output file, and that the results should be saved as text. 
-oa specifies that the next argument is an output file, and that the results should be saved as a SmartWhois archive. 
-ox specifies that the next argument is an output file, and that the results should be saved as XML. 
-oe specifies that the next argument is an output file, and that the results should be saved as XLS. 
-h specifies that the query is processed without opening the program's main window. Please note that the SmartWhois 

tray icon will always be displayed when this parameter is used. The icon will disappear when the program's main 
window is opened by right-clicking on the icon and selecting "Show" from the menu, or by double-clicking on the 
icon. 

-c Specifies that the program should be closed when done. This parameter must be used with the output format 
defining parameters (-oa, -ot, -ox, -oe) and the file name where the results will be written. It must always follow 
them. 

 
 
Examples: 
 
SW.EXE -b -si C:\LOGS\list.txt -ot C:\LOGS\results.txt 
The program reads IP addresses from list.txt, processes the list, and saves the results to results.txt in plain text format. 
 
SW.EXE -b -si C:\LOGS\list.txt -ox C:\LOGS\results.xml 
The program reads IP addresses from list.txt, processes the list, and saves the results to results.xml in XML format. 
 
SW.EXE -b -sd C:\LOGS\domains.txt  
The program reads domains from list.txt and processes the list without saving results. 
 
SW.EXE -b -sd C:\LOGS\list.txt -oa "C:\Business Data\my domains.swh" -c 
The program reads domains from list.txt, processes the list, saves the results to mydomains.swh as a SmartWhois archive, and 
exits. 
 
Important: If a file name or its path contains spaces, it must be enclosed in quotation marks (" "). 



 

Saving Results 
 
SmartWhois allows you to save query results as a SmartWhois archive, TXT, XML, XLS, or HTML file. The TXT files can be saved in 
ANSI, Unicode UTF-8, and Unicode UTF-16 formats. If you want to save the current query output to a SmartWhois archive, click 
File =>Save => Current Result =>As SmartWhois Archive. In this case the contents of the Results tree and the text area 
related to the current query are saved.  To save query results as HTML, XML, XLS, or TXT file, click File =>Save => Current 
Result =>As HTML File / As Text File / As XML File / As XLS File. Only the information from Text Area will be saved.  
 
You can also save all query results to a SmartWhois archive by clicking File =>Save => All Results. All contents of the Results 
tree and the corresponding output will be saved.  
 
If you're saving results as a text, XML, or XLS file, you can specify the data fields to be saved; for example, you can exclude name 
servers or billing contact from the output file. Click Settings => Options => Export to configure the options. If you save the 
query result as text, you may get rid of the names of data sections by checking the Don't include tags checkbox. 
 
Additionally, you can drag the contents of the left or right panel to any folder. If you drag data from the left panel, the resulting file 
will be in SWH (SmartWhois archive format). If you drag data from the right panel, the resulting file will be in HTML format. 



 

Whois Console 
 
Whois console is used for making special queries or for querying a non-default whois server. Sometimes a standard query output 
would create a need for making a special query to obtain more detailed information. Here is an example of a standard query output 
for the domain macrovision.co.jp: 
 

 
 
 
You see that Tech and Admin information cannot be retrieved with a standard query. Let's suppose you need to obtain the technical 
support contact information. You can open the Whois Console by clicking View => Whois Console or Query => Custom 
Query, type in whois.nic.ad.jp for whois server and YM676JP /e for query, where YM676JP is the administrator's handle and /e is 
used for suppressing Japanese output. Click Connect and you will see the following output: 
 



 
 

Whois Console has a built-in list of many whois servers located all over the world. To select a server from the list, click on the 
Select button. If you want to customize or update this list, click on the Select button, and the list of servers will be displayed. To 
add a new server to the list, click on the Add button and specify the address of the server in the Server field, select the country in 
the Country box, and add an optional description. If you would like to edit an entry from the list, select it and click on the Edit 
button. To delete an entry, select it and click on the Delete button.  
 
Right-clicking on the list of servers brings up the following menu: 
 
Select – enters the selected server into the Whois Server field in Whois Console. 
 
Add – brings up a dialog window for adding a server to the list. 
 
Edit – brings up a dialog window for editing the selected server. 
 
Delete – deletes the selected server from the list. 
 
Copy – copies the entire list of servers or the selected entry, server address, country, or description to the clipboard. 
 
Save As – saves the list of servers in text, HTML, XML, or XLS format.  
 
Right-clicking on Whois Console window brings up the following menu: 
 
Clear – clears the Whois Console window. 
 
Copy – copies the selected text to the clipboard. 
 
Select All – selects all text in the output area. 
 
Save As – saves the query result as text file. 
 
Font – allows you to select the font for the Whois Console window. 
 
Auto Clear – when enabled, the current query results are deleted before processing the next query.  
 
Auto Scroll – automatically scrolls down to the bottom of the query result text. 
 
Word Wrap – toggles word wrap for the query result text in the Whois Console window.  



 

My Notes 
 
You can save your notes about domains or IP addresses using the View => My Notes dialog. To add a note, click on the Add 
button and specify the IP address / domain in the Address field, add your note in the box below, and click OK. If you would like to 
edit an entry from the list, select it and click on the Edit button. To delete an entry, select it and click on the Delete button. You 
can sort the entries by IP address / domain or by the note's text if you click on the name of the column at the top of the window. 
 
Right-clicking on the list of notes brings up the following menu: 
 
Add – brings up a dialog window for adding a new note. 
 
Edit – brings up a dialog window for editing the selected note. 
 
Delete – deletes the selected note from the list. 
 
Copy – copies all notes, the selected note, IP address / domain, or the note text to the clipboard. 
 
Save As – saves the notes in text, HTML, XML, or XLS format.  
 
Whenever SmartWhois displays information about an IP address or domain, it checks for corresponding user notes. If they exist, 
SmartWhois displays a hyperlink at the bottom of the right panel indicating that you entered certain information about the given IP 
address or domain in the past. You can click on the hyperlink to have your notes displayed. 



 

Country Codes 
 
Every country in the world is assigned a two-letter abbreviation. These abbreviations are used for identifying the geographic 
location of a hostnames and domain and are also called Top Level Domains (TLD). You can see the list of TLDs by clicking View 
=> Country Codes. You can sort the entries by country names or codes by clicking the Country or Code column at the top of 
the window.  
 
Right-clicking on the list of notes brings up the following menu: 
 
Copy – copies the list of countries and codes, the selected entry, country, or code to the clipboard. 
 
Save As – saves the entries in text, HTML, XML, or XLS format.  
 
 
The most up-to-date official TLD list is available at http://www.iana.org/cctld/cctld-whois.htm 
 

http://www.iana.org/cctld/cctld-whois.htm


 

Source Viewer 
 
SmartWhois allows you to view a raw server response as it was received from the whois server. Since raw data received from the 
whois server provides the entire contents of the corresponding record in an unmodified form, it may be useful to view it in certain 
cases, because SmartWhois may sometimes omit part of the information, as output formats vary greatly. This feature is also useful 
for reading error messages produced by whois servers. Viewing source is not possible for cached records.  
 
Right-clicking on Source Viewer window brings up the following menu: 
 
Copy – copies the selected text to the clipboard. 
 
Select All – selects the entire contents of the Source Viewer window. 
 
Save As – saves the raw query output to a text file. 
 
Font – allows you to change the font of the text in the window. 
 
Word Wrap – toggles the word wrap for the text in the window.  



 

Configuring Abuse Templates 
 
SmartWhois is capable of creating and sending abuse reports to domain or network block owners. The application uses preselected 
templates; however, you may customize the desired template(s) or even add your own.  
 
To configure templates, right-click on the text area (the right panel) and select the Abuse / Spam Reporting => Configure 
option in the context menu. Depending on your needs, either click the Add button to add a new template or use the Edit button to 
edit an existing one. 
 
Template Format and Keywords 
 
There are no special template specifications except that you have to be sure to include special keywords in the template text. If the 
current template is to be used as an abuse report to a domain owner, make sure to include the <DOMAIN> keyword in the 
template body. Otherwise, include the <IP> keyword in the template body (if the current template is a report for IP address / 
network block owners). Those keywords will be substituted by the actual domain name or IP address when generating a report. 
 
An optional keyword that can also be used in the template body is <OWNER>. Use this keyword if you want the domain or IP 
address owner information to be included in the abuse report. 
 
Sending Reports 
 
To send an abuse report, select the desired item (domain or IP address) in the Results tree, and search for the Abuse contact (if 
available) or the generic contact e-mail address. Once you locate the contact of the desired network resource and his/her e-mail 
address, right-click on the e-mail address, select Send report to…., and select the template you want to be used as a report. 
SmartWhois will generate an e-mail message based on the selected template and open it in your favorite e-mail client. Please make 
sure that you include all the details about the network attack or spam message headers in the message. 



 

Integration Options 
 
SmartWhois comes with plug-ins for Microsoft Internet Explorer, Maxthon Browser, Mozilla/SeaMonkey Navigator, Mozilla Firefox, 
Netscape Browser, Flock, Microsoft Outlook, and Windows Explorer for quick and easy querying of IP addresses / hostnames / 
domains and/or batch processing directly from these applications. Please see the next sections for the information on these plug-
ins.  
 
 
 

MS Outlook Add-in 
 
Select one or more messages and click Pass E-mail headers to SmartWhois in the drop-down menu of the SmartWhois button 
on the "Standard" Outlook toolbar. A separate window opens for each of the messages selected. IP addresses in the window are 
displayed as hyperlinks; clicking on them will make SmartWhois perform an IP address query. You can also highlight any text and 
select the query type in the context menu. 
 
Installation/Removal: 
 
Turn on/off the Install Microsoft Outlook add-in option on the Options => Integration page in SmartWhois.  
 
 
 

Microsoft Internet Explorer Extension 
 
To perform a SmartWhois query for the current URL, click the SmartWhois button on the toolbar or select SmartWhois in the 
Tools menu. 
 
Installation/Removal: 
 
To install/uninstall the plug-in turn on/off the Install Microsoft Internet Explorer extension option on the Options => 
Integration page in SmartWhois. If you don't see the SmartWhois button on the toolbar after the plug-in installation, right-click on 
the Internet Explorer toolbar, select  Customize…  and add SmartWhois to the Current toolbar buttons list. 
 
 
  

Maxthon Browser Plug-in    
 
To perform a SmartWhois query for the current URL, click the SmartWhois button on the Plugins Bar toolbar. 
 
Installation/Removal: 
 
Turn on/off the Install Maxthon Browser plug-in option on the Options => Integration page in SmartWhois.  
 
 
 

Mozilla/SeaMonkey Navigator Extension 
 
To perform a SmartWhois query for the current URL or hyperlink, select SmartWhois Query/Send Link To SmartWhois in the 
context menu of the page or hyperlink.  
 
Installation: 
 
Find the swlaunch.xpi file in the SmartWhois application folder, drag it to the browser window and follow further instructions. 
 
Removal: 
 
By default, Mozilla/SeaMonkey Navigator does not have the functionality for automatic extension removal. You can use one of the 
third-party extension managers, for example, ExtensionManager by Jeremy Gillick (you will also need to install ExtensionUninstaller 
API to make it work). 
 

https://addons.mozilla.org/mozilla/203/
https://addons.mozilla.org/mozilla/202/
https://addons.mozilla.org/mozilla/202/


 
 

 Mozilla Firefox Extension 
 
To perform a SmartWhois query for the current URL or hyperlink, click the SmartWhois button on the toolbar or the SmartWhois 
Query/Send Link to button in the context menu of the page or hyperlink.  
 
Installation: 
 
Find the swlaunch.xpi file in the SmartWhois application folder, drag it to the browser window and follow further instructions. If 
you don't see the SmartWhois button on the toolbar after the extension installation, then right-click on the toolbar, select 
Customize…  and drag SmartWhois to a desired spot on the toolbar. 
 
Removal: 
 
Go to the Tools = > Add-ons menu and select SmartWhois Launcher in the window that appears. Click Uninstall and follow 
further instructions. 
 
 

Netscape Browser Extension 
 
To perform a SmartWhois query for the current URL or hyperlink, click the SmartWhois button on the toolbar or SmartWhois 
Query/Send Link to button in the context menu of the page or hyperlink.  
 
Installation: 
 
Find the swlaunch.xpi file in the SmartWhois application folder, drag it to the browser window and follow further instructions. If 
you don't see the SmartWhois button on the toolbar after the extension installation, then right-click on the toolbar, select 
Customize…  in the context menu and drag SmartWhois from the Functional page to a desired spot on the toolbar. 
 
Removal: 
 
Select Tools => Extensions and click SmartWhois Launcher in the dialog window. Click Uninstall and follow further 
instructions. 
 
 

Flock Extension 
 
To perform a SmartWhois query for the current URL or hyperlink, click the SmartWhois button on the toolbar or SmartWhois 
Query/Send Link to button in the context menu of the page or hyperlink.  
 
Installation: 
 
Find the swlaunch.xpi file in the SmartWhois application folder, drag it to the browser window and follow further instructions. If 
you don't see the SmartWhois button on the toolbar after the extension installation, then right-click on the toolbar, select 
Customize…  in the context menu and drag SmartWhois to a desired spot on the toolbar. 
 
Removal: 
 
Select Tools => Extensions and click SmartWhois Launcher in the dialog window. Click Uninstall and follow further 
instructions. 
 
 

Windows Explorer Shell Extension 
 
For quick batch processing of the files selected in Windows Explorer, right-click, select SmartWhois, and choose the corresponding 
format in the context menu. 
 
 
Installation/Removal: 
 
Check/uncheck the Enable Windows Explorer Shell Extension checkbox on the Options => Integration page of 
SmartWhois.  



 

Update Wizard 
 
SmartWhois has a built-in capability to check for the updates at the TamoSoft web site. If the program finds out that the installed 
version is older than the one on the server, it will prompt you to download and install the update. You can make SmartWhois check 
for the available updates automatically each time the program is started by checking the Enable automatic application updates 
checkbox on the Settings => Options => Updates window. Alternatively, you can do it manually by clicking on the Help => 
Check for an Update menu item. This will launch the Update Wizard that will guide you through the updating process.  
 
If no updates are available, the Wizard will inform you accordingly and close, otherwise a window will appear that will show the 
description of the update. Check the Skip the update and prompt me for the next one checkbox if you don't want to install 
this update. Check the Do not check for updates in the future checkbox if you would like to disable the automatic update 
feature. Click on the Next button to continue with the upgrade. The next screen will allow you to specify the location where you 
would like to save the upgrade package. You can enter the path manually, or click on the Browse button to browse to a folder. 
Click on the Next button to begin downloading the package. After the package has been downloaded, you will see the confirmation 
screen. Please check the Execute the downloaded file checkbox if you would like to install the update immediately, or leave it 
unchecked if you prefer to do it at a later time. 
 



 

Configuring SmartWhois 
You can customize the application configuration by clicking Settings => Options.  

Queries 
 
Default query type (hotkey) – select the query type to be used as the default when clicking on the Query button or pressing 
the Enter key. By default, the Auto Detect query type is selected. With this query type, the application will try to guess if you 
expect it to perform an IP address/hostname of domain query. If you need more control over what the application does, select a 
different query type as the default. All other query types are explicit, i.e. they don't involve any "guesswork" from the application 
side. 
 
Simultaneous query processing threads – sets the maximum number of simultaneous threads processing queries. This value is 
set to "10" by default. That value is considered as the optimal one for most computers. You don't need to change this value unless 
you are unsatisfied with the query processing performance. 
 
Query time-out – this field sets the time limit for each query. If no information is received during the specified time, the query is 
cancelled. Depending on the speed of your Internet connection and the accessibility of whois servers you may want to increase or 
decrease the query timeout. 

Prompt to re-query unfound items when processing batch files – check this box if you want SmartWhois to prompt you to 
re-query a batch file. Sometimes the program cannot get information on all the items in the batch file due to whois server time-outs 
or temporary database problems. In such cases SmartWhois will suggest to scan the batch file once again and send queries for 
those items that were not initially found.  

Automatically de-obfuscate URLs – check this box to have the program decode obscure (or standard) URLs when you paste 
them to the input field. An example of such a URL is: http://new.sec.34333QQ@193490259912/o%62s%63ur%65%2e%68t%6D . 
 
Sort query history – when this box is checked, the query history (recent queries in the program's drop-down list) is sorted 
alphabetically. 

Clear query history on exit – if this box is checked, the application clears the query history when you exit. 

Clear results on exit – if this box is checked, the application clears the Results tree when you exit. 
 
 
Automatically perform query: 
 
When an item is selected from the history list – runs a query when an item is selected from the drop-down list. 
 
When text is pasted into the query box – runs a query when the clipboard text is pasted into the query box. 
 

Network 

 

Ping 

Check if host is reachable (ping) – checks if the host is reachable at the moment by pinging it. If the box is checked, 
SmartWhois sends pings (echo requests) to the host and waits for the reply. If the host is geographically too far away from you, 
some of the pings can be lost en route because this kind of network packets have the lowest priority. Due to this reason the 
program usually sends more than one ping (4 by default) and the response time is calculated as a mean value. You can change the 
number of pings by modifying the value in the corresponding box.  The time-out box displays the maximum time the program will 
wait for ping replies. 

Disable ping when processing batch files – prevents the program from pinging each host or IP address contained in the batch 
while making queries. 

Ping IPv6 addresses – if this box is checked, SmartWhois sends pings to an IPv6 host. We suggest that you disable this option if 
you're running Windows XP or older operation system, or experience difficulties pinging IPv6 addresses. Disabling this option may 
result in increasing the query processing performance. 

Custom ping message – allows you to change the default string contained in ping packets.  To use this feature, check this box 
and type your own message in the textbox below. 

http://new.sec.34333QQ@193490259912/o%62s%63ur%65%2e%68t%6D


 

Proxy Servers  

If the computer running SmartWhois does not have a direct Internet access, you need to configure SmartWhois proxy settings in 
order to perform whois queries.  

Use proxy server - check this box if your PC is part of a LAN and doesn't have direct access to the Internet or you wish to use an 
external proxy. 

Manage proxy servers – click on this button to configure your proxy servers. See the Using SmartWhois From Behind a Firewall 
chapter for more information on configuring proxy servers. 

Use the selected proxy server – check this box if you want to use a single preselected proxy server for all connections. 

Use a random proxy server from the list – chose this option to instruct the program to use random proxy from the list every 
time when a new connection to the whois server is made. 

 

Advanced 

Query all IP addresses assigned to hostname – if this option is enabled, SmartWhois will retrieve all IP addresses assigned to 
a specified hostname and query them separately. Multiple IP addresses will be displayed as the child branches of the specified host. 

Reverse resolve IP address to hostname – if this box is checked, the program will try to resolve the host name for the entered 
IP address when you send a query. 

Check for geolocation DNS record (DNS LOC) – check this box to have SmartWhois report the geographic coordinates of a 
domain / IP address being queried. Please see our FAQ for more information on viewing LOC records. 

Check for Google Page Rank / Check for Alexa Traffic Rank – enable these options to have the program display Google 
Page and/or Alexa Traffic ranks. Note that enabling these options may slow down the program's performance slightly, as additional 
network connections are needed for displaying this information. 

Show IPv6 ranges as CIDR – if this option is enabled, IPv6 ranges in the Results tree will be shown in the CIDR format. This 
saves some space in the left panel. 

 

Cache 

SmartWhois is capable of caching the output of all queries, as well as maintaining a DNS lookup results cache for future use. If you 
enter an IP address or a host name that has been previously queried the program finds the query results in the cache and 
immediately displays the information even if you are not connected to the Internet. 

 

Data 

Enable data caching – use this checkbox to enable this feature.  

Current number of records – indicates the number of currently stored records. 

Maximum number of records – allows you to adjust the cache size in terms of records. 

View Cache – allows you to view cached records.  

Clear Cache – purge the cache. 

Clear cache on exit – purge the cache every time the application is closed. 

 

DNS 

Enable hostname / IP address caching – check this box if you want SmartWhois to cache DNS queries. On the Internet a 
Domain Name Server (DNS) mechanism is used for resolving hostnames to IP addresses. Usually your computer queries the DNS of 
your Internet Service Provider (ISP) for an IP address corresponding to a hostname. However it is possible to have DNS information 
stored on your local computer, which may make the program work faster.  

Current number of records – indicates the number of records currently stored. 

Maximum number of records – allows you to adjust the DNS cache size in terms of records. 

View Cache – allows you to view cached DNS records.  

Clear Cache – purge the DNS cache. 

Clear cache on exit – purge the cache every time the application is closed. 

Remember that hostnames corresponding to IP addresses can be changed by their owner. The whois server authority can change 
high-level DNS records, and if you have an old record in your local DNS cache SmartWhois might be unable to access these hosts. 
Clearing the local DNS cache can solve this problem. 

 



Export 

This tab allows you to configure the fields to be included in text, XLS, or XML files when you save results. 

Don't include tags when saving as text file – if this box is checked, the text output will not contain such tags as <ip address> 
or <administrative contact>. When exporting the data to XML and XLS formats the tags are always included. 

Integration 

This page is for managing a number of plug-ins and add-ons that allow SmartWhois to integrate with browsers and e-mail 
applications. You can install or remove the following options: 

• Microsoft Internet Explorer Extension 

• Microsoft Outlook Add-in 

• Maxthon Browser Plug-in 

• Mozilla/SeaMonkey Navigator Extension 

• Mozilla Firefox Extension 

• Netscape Browser Extension 

• Flock Extension 

• Windows Explorer Shell Extension 

Please refer to the Integration Options chapter for the details and installation instructions. 

 

System 

Run on Windows Startup – if this box is checked, the program is automatically launched every time you start Windows. 

Show Tray Icon – if this box is checked, a SmartWhois icon will be displayed in the system tray area. Right-clicking on it pops up 
a menu for quick access to the frequently used SmartWhois functions. If you would like to open the program's main window, double 
click the icon or right-click on it and select Show from the pop-up menu. 

Close to tray – if this box is checked, the program's main window is minimized on closing, and a SmartWhois icon is displayed in 
the system tray area. Use the Exit command of the icon's context menu to close the program. 

On startup minimize to tray – if this box is checked, SmartWhois will run minimized every time it is launched. If you would like 
to open the program's main window, double-click the SmartWhois icon or right-click on it and select Show from the pop-up menu. 

Single click on tray icon to open - check this box if you want to open the main window with a single click. 

 
Hotkeys 

This page contains hotkeys that allow you to open a number of SmartWhois and perform clipboard and window queries. To enable 
a hotkey, check the corresponding box and use your keyboard to select a unique hotkey for the selected action (e.g. hold down Ctrl 
+ Shift + H) then click OK. Note that the selected hotkey combinations should be unique in order to not create conflicts with 
hotkeys assigned by other applications. 

 
Fonts & Colors 

SmartWhois' look can be customized on this page. Both the left and right panels may be assigned with the unique background color 
and font. You can also change the application font that is used in dialogs and menus. Use the Restore Defaults button to roll back 
to the default settings. 

 
Updates 

Enable automatic application updates - if this box is checked, the program will check if an update for the current version is 
available and will prompt you to download and install it. You may want to set the interval between SmartWhois update checks in 
the Interval between checks field. 

Click on the Check for Updates Now button to check for available updates immediately. 

 



 

Using SmartWhois From Behind a Proxy / Firewall 
 

On many corporate networks, Internet access is restricted due to security or other reasons. If the computer running SmartWhois 
does not have a direct Internet access, you need to configure SmartWhois proxy settings in order to perform whois queries. 

SmartWhois allows you to use two different proxy server types: SOCKS and HTTP/HTTPS.  You should choose the appropriate type 
of proxy server depending on your network setup. Please contact your network administrator for the information about which proxy 
server is available on your network. If you have a SOCKS proxy available, you need to configure SOCKS proxy server settings in 
SmartWhois. If you access the Internet through HTTP/HTTPS proxy (usually in LANs where only the HTTP protocol is allowed), 
please set the respective HTTP/HTTPS proxy server settings. SmartWhois can only work through proxies that support the CONNECT 
request method. Please note that even if the HTTP proxy server your company uses for the Internet access supports the CONNECT 
request method, it must be enabled by the network administrator as this option is often disabled by default. For more information 
on the HTTP protocol, please refer to RFC 2616: 

http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html 

If you are using a proxy server for accessing the Internet, click Settings => Options, select the Proxy Servers page, and then 
select the Use proxy server option. Click on the Manage proxy servers button to configure a proxy(s). The proxy list is initially 
empty, so you need to add proxy servers by clicking on the Add button. The settings page will be displayed: 

Proxy server type – type of a proxy server:  HTTP, SOCKS v4, SOCKS v4a, and SOCKS v5 types are available. 

Host name – proxy server host name or IP address. 

Port number – proxy server port number. 

Check the User Authentication box and enter your credentials (user ID and password) in the corresponding fields if your proxy 
server requires user authentication.  

Once you're done with configuring a proxy, select the desired server in the proxy list and click on the Test button to test the 
connection with a proxy. SmartWhois will attempt to establish a connection with a server and show the proxy status depending on 
the test results: 

 - not tested yet. 

 - test passed. 

 - an error occurred during the establishment of a connection. 

You can hover the mouse over a proxy that failed a test to see a hint with the detailed error information. 

 

 

http://www.w3.org/Protocols/rfc2616/rfc2616-sec9.html


If you are behind a firewall, you may also want to check the Don't resolve hostnames locally box. This is useful when your 
computer doesn't have access to a DNS server. If this box is checked, SmartWhois will not try to resolve the whois server addresses 
locally. Rather, the program will pass them to the proxy server for resolving. The only limitation for computers that don't have 
access to a DNS server is that SmartWhois will be able to process only IP address and domain queries, but not hostname queries. 



 

Frequently Asked Questions 
 
Q.: Can I use SmartWhois if I'm behind a firewall or a proxy server? 

A.: Yes, SmartWhois supports SOCKS firewalls and HTTP/HTTPS proxy servers (they must support the CONNECT method). If your 
firewall is not SOCKS-compliant, you'll have to configure it to allow network traffic on TCP ports 43 and 80. Please refer to your 
proxy server's documentation or contact your network administrator for information on configuring (mapping) proxy ports. Also, see 
the Using SmartWhois From Behind a Firewall chapter of the help file for more detailed information. 
 
 
Q.: I made a query using wildcard, but the program's status bar displays "Connection timed out" before I get any 
results. How can I make it work? 

A.: Using wildcard queries usually takes longer to retrieve data than using normal queries. To handle this problem, you should set a 
longer timeout period (Settings => Options => Queries). For example, you can change the timeout period from 45 seconds to 
100 seconds.  
 
Q.: Why do I get the "Connection timed out" or "Connection failed" errors? 

A.: There are several possible reasons:  
 

• Your connection to the Internet is too slow or "fuzzy," which usually happens when you have a low quality telephone line. 
Try to reconnect to your ISP.  

• The Whois server the program is connecting to is down. SmartWhois obtains information from official whois databases, 
and these databases are not in our control. So you'll have to wait until the server is up and running again, which normally 
doesn't take long.  

• If you enabled IP address/hostname caching in the Options, the program might fail to connect to a Whois server if its IP 
address has recently changed. Click Clear Cache in Settings => Options => Cache => DNS.  

• Your network environment does not permit outbound TCP connections on ports 43 and 80. This is often the case when 
you don't have direct Internet access, e.g. you are behind a corporate firewall, or if you installed a personal firewall with 
incorrectly configured packet-blocking rules. 

 
Q.: When running a batch query, I only get certain percentage of the domains / IP addresses processed. Why some 
of the records are unavailable?  

A.: Many whois databases temporarily or permanently ban an IP address after receiving a certain number of queries over a fixed 
period of time. To avoid being banned, we suggest that you use a great number of proxy servers for connecting to whois severs. 
SmartWhois is capable of selecting a random server from the proxy list every time the application connects to a whois server. This 
may help you avoid being banned. Please refer to the Using SmartWhois From Behind a Proxy / Firewall chapter of SmartWhois 
manual for more information on configuring proxy servers. 
 
Q.: Can I call SmartWhois directly from my application? 

Yes. You can use the command-line interface to send an IP address or domain to SmartWhois and run the query. Please see the 
Command Line Options chapter of the manual for more information on command-line usage examples. 
 
Q.: My firewall software warns me that SmartWhois is "attempting to access the Internet." I am aware that some 
sites are able to track users by collecting the information sent by their programs via Internet. Why does 
SmartWhois "attempt to access the Internet"? 

A.: What alerts your firewall are the attempts to connect to Whois databases to fetch the requested records, and the attempts to 
connect to DNS serves to resolve IP addresses to hostnames. The primary function of the program is to obtain the most current 
records available from whois databases; therefore SmartWhois makes outbound connections on TCP ports 43 and 80 and UDP port 
53. Additionally, the program may check for updates by contacting www.tamos.com (this functionality can be disabled). There are 
no other hidden activities. We don't sell spyware. 
 
Q.: When I click on the SmartWhois icon in the Microsoft Internet Explorer or Firefox toolbar, the program box 
flashes up briefly and then vanishes. Why this feature isn't working? 

A.: The SmartWhois plug-in window is displayed only when it is active, and it is automatically closed when the focus is moved to 
another window. Most likely you have a software running that is changing the focus and activates other windows, or always moves 
its window on top. We would suggest to close all other running applications one by one to see which one is affecting SmartWhois.  

Another reason for this behavior could be the mouse cursor settings on your computer. Certain mouse driver utilities allow you to 
configure the cursor to activate the window under the cursor, or even bring it to the foreground. When these features are enabled, 
they will prevent SmartWhois window from staying open.  
 
Q.: I can't see the owner information when querying Chinese or Japanese domains; I see gibberish instead of 
characters. 
 
A.: To see text in East Asian languages, you should install East Asian fonts in Windows. Open Control Panel => Regional and 
Language Options, select the "Languages" tab, and check the "Install files for East Asian languages" box. 
 

http://www.tamos.com/


 
Q.: What are LOC records and are they supported by SmartWhois? 

A.: An LOC record stands for geographic location information: some domains and IP addresses may have a special DNS record that 
stores the object location coordinates (Latitude, Longitude, etc.). SmartWhois can query this information and generate a Google 
Map link to view the location of an object on the map. 

Q.: What are internationalized domain names and are they supported in SmartWhois? Что такое  

A.: An internationalized domain name (IDN) is an Internet domain name that contains one or more non-ASCII characters. Such 
domain names could contain letters with diacritics, as required by many non-English languages, or characters from non-Latin scripts 
such as Arabic, Hebrew, Chinese or Hindi. And, yes, SmartWhois supports IDN queries. 

Q.: IPv6 queries don't work for me. Is there anything I can do about it? 

A.: To successfully make IPv6 queries you need to have Windows XP or later operating system installed. If you're running Windows 
XP, the IPv6 support should be installed. To install it, open a Command Prompt window and execute the following command: 
 
netsh interface ipv6 install 
 
Note: IPv6 is not supported on Windows 2000 or earlier operating systems. 
 

http://en.wikipedia.org/wiki/LOC_record
http://en.wikipedia.org/wiki/Internationalized_domain_name


 

Information 
 

How to Purchase SmartWhois  
 
This program is a 30-day evaluation version. If you would like to continue using it after 30 days, you must purchase it. 
 
As a registered customer you are entitled to:  
 

• Free updates that will be released within 1 year from the date of purchase; 
• Information on updates and new products; 
• Free technical support.  

 
We accept credit cards orders, orders by phone and fax, checks, and wire transfers. Prices, terms, and conditions are subject to 
change without notice; please check our web site for the latest product offerings and prices. 
 
http://www.tamos.com/order/ 

http://www.tamos.com/order/


 

Contacting Us 
 

Web 
 
http://www.tamos.com  
 
 

E-mail 
 
 
sales@tamos.com (Sales-related questions)  
support@tamos.com (All other questions)  
 
 

Mail and Fax 
 
Mailing address: 
 
PO Box 1385 
Christchurch 8140 
New Zealand  
 
Fax: +64 3 359 0392 (New Zealand) 
Fax: +1 917 591 6567 (USA) 

http://www.tamos.com/
mailto:sales@tamos.com
mailto:support@tamos.com


 

Other Products by TamoSoft 
 
CommView  
 
CommView is a program for monitoring Internet and Local Area Network (LAN) activity capable of capturing and analyzing network 
packets. It gathers information about data passing through your dial-up connection or Ethernet card and decodes the analyzed 
data. With CommView you can see the list of network connections and vital IP statistics and examine individual packets. Packets are 
decoded down to the lowest layer with full analysis of the most widespread protocols. Full access to raw data is also provided in 
real time. CommView is a helpful tool for LAN administrators, security professionals, network programmers, or anyone who wants to 
have a full picture of the traffic going through one's PC or LAN segment. 
 
More information 
 
 
CommView for WiFi 
CommView for WiFi is a powerful wireless network monitor and analyzer for 802.11 a/b/g/n networks. Loaded with many user-
friendly features, CommView for WiFi combines performance and flexibility with an ease of use unmatched in the industry. 
CommView for WiFi captures every packet on the air to display important information such as the list of access points and stations, 
per-node and per-channel statistics, signal strength, a list of packets and network connections, protocol distribution charts, etc. By 
providing this information, CommView for WiFi can help you view and examine packets, pinpoint network problems, perform site 
surveys, and troubleshoot software and hardware. 
 
More information 
 
 
NetResident  
 
NetResident is an advanced network content monitoring program that captures, stores, analyzes, and reconstructs network events 
such as e-mail messages, Web pages, downloaded files and instant messages. NetResident uses advanced monitoring technology to 
capture the required data from the network, saves it to a database, reconstructs it, and displays this content in an easy-to-
understand format. While NetResident is similar to network analyzers in many respects, it focuses on high-level protocols that are 
used to transfer content over the Internet or LAN. With NetResident, you don't need a profound understanding of networking 
technologies, have to use complex packet capturing and analysis software, or dig through network packets in order to reconstruct 
the actual data; NetResident does all the work for you and presents only the Web pages, e-mails, instant messages, or downloaded 
files as requested. NetResident is used by network administrators to enforce IT policy, parents to monitor their children's 
communication on the Internet, and by forensic experts to gain crucial information. 
 
More information 
 
 
CommTraffic 
CommTraffic is a network utility for collecting, processing, and displaying traffic and network utilization statistics for network 
connections, including LAN and dial-up. It shows traffic and network utilization statistics for each computer in the segment. The 
software provides a very attractive and customizable interface, with an optional tray icon menu that displays general network 
statistics. You can also generate reports that reflect the network traffic volume and Internet connection expenses (if any). 
CommTraffic supports virtually any rate plan your ISP might use, such as the one based on connection time, traffic volume, time of 
the day, and other measures. You can set alarms that will inform you when certain criteria (e.g. amount of traffic, expenses) are 
reached. A configuration wizard will guide you through the setup and automatically detect your network or connection settings. 
More information 
 
 
CountryWhois 
 
CountryWhois is a utility for identifying the geographic location of an IP address. CountryWhois can be used to analyze server logs, 
check e-mail address headers, identify online credit card fraud, or in any other instance where you need to quickly and accurately 
determine the country of origin by IP address. 
 
More information 
 
 
Essential NetTools 
Essential NetTools is a set of network tools useful in diagnosing networks and monitoring your computer's network connections. It's 
a Swiss Army knife for everyone interested in a set of powerful network tools for everyday use. The program includes a NetStat 
utility that shows your computer's network connections and open ports and maps them to the owning application. It also features a 
fast NetBIOS scanner, a NetBIOS Auditing Tool for checking LAN security, and a monitor of external connections to your computer's 
shared resources, as well as a process monitor that displays information about all the programs and services running on your 
computer. Other useful tools are included, such as Ping, TraceRoute, and NSLookup. Additional features include report generation 
in HTML, text, and comma delimited formats and a customizable interface. The program is an easy-to-use and powerful 
replacement for such Windows utilities as nbtstat, netstat, and NetWatcher. It incorporates many advanced features that standard 
Windows tools can't offer. 
 
More information 
 

http://www.tamos.com/products/commview/
http://www.tamos.com/products/commwifi/
http://www.tamos.com/products/netresident/
http://www.tamos.com/products/commtraffic/
http://www.tamos.com/products/countrywhois/
http://www.tamos.com/products/nettools/


 
DigiSecret 
DigiSecret is an easy-to-use, secure, and powerful application for file encryption and sharing. It utilizes strong and time-proven 
encryption algorithms for creating encrypted archives, self-extracting EXE files, and sharing files with your associates and friends. 
DigiSecret also includes powerful and intelligent file compression; you no longer need .zip files when you can have encrypted and 
compressed DigiSecret files. The program is integrated with the Windows shell, and you can perform operations on files by right-
clicking on them. It also fully supports drag-and-drop operations. 
 
More information 
 

http://www.tamos.com/products/digisecret/
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